Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Help please. Installed ubuntu 11.10 32bit on lenovo ideapad z570. When choosing Network Manager > Enable Wireless nothing happens. WiFi not enabling

Tried the response of Wireless problems with Atheros AR9285

Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express)

code output for :sudo lshw -class network

*-network DISABLED      
       description: Wireless interface
       product: AR9285 Wireless Network Adapter (PCI-Express)
       vendor: Atheros Communications Inc.
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: wlan0
       version: 01
       serial: d0:df:9a:a0:c3:5a
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=ath9k driverversion=3.0.0-12-generic firmware=N/A latency=0 link=no multicast=yes wireless=IEEE 802.11bgn
       resources: irq:17 memory:d0500000-d050ffff
  *-network
       description: Ethernet interface
       product: RTL8101E/RTL8102E PCI Express Fast Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: eth0
       version: 05
       serial: f0:de:f1:72:0e:89
       size: 100Mbit/s
       capacity: 100Mbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=rtl_nic/rtl8105e-1.fw ip=192.168.0.103 latency=0 link=yes multicast=yes port=MII speed=100Mbit/s
       resources: irq:40 ioport:2000(size=256) memory:d0404000-d0404fff memory:d0400000-d0403fff

rfkill list all

0: ideapad_wlan: Wireless LAN
    Soft blocked: no
    Hard blocked: yes
1: ideapad_bluetooth: Bluetooth
    Soft blocked: no
    Hard blocked: yes
2: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: yes
3: acer-wireless: Wireless LAN
    Soft blocked: yes
    Hard blocked: no
share|improve this question
    
please add the output of sudo lshw -class network as well as rfkill list all to your question. –  fossfreedom Nov 6 '11 at 7:42
    
Thanks for the response. output added. –  Venkat Kotra Nov 6 '11 at 16:18
    
dont forget that this is a question and answer site - so you should not post answers when describing the latest situation - just reedit your question and add the latest info. The latest info shows that acer-wmi was the key culprit - now that has been removed you've got a hardware switch to toggle. As I said in my answer, you'll need to find that on your laptop - its either a physical switch (maybe tucked under a flap) or a keyboard Fn key type switch. –  fossfreedom Nov 9 '11 at 7:31
    
@fossfreedom after following your suggestion, i will try to figure out where the hardwares switch is and post it here for information of other. Thanks. –  Venkat Kotra Nov 9 '11 at 12:55
    
Am exactly suffering from this problem bbs.archlinux.org/viewtopic.php?id=122601 –  Venkat Kotra Nov 11 '11 at 5:38
show 1 more comment

2 Answers 2

You may be suffering from a clash with the acer-wmi kernel module.

rfkill list all says it is "acer-wireless: soft blocked: yes"

try the following:

sudo modprobe -r acer-wmi
cd /etc/modprobe.d
sudo nano blacklist.conf

Then add blacklist acer-wmi as a new line at the end of the file.

Save and reboot.

Rerun rfkill list all again - if there still is a "hard-block" you have disabled the wifi via a switch or a Fn key type wireless on/off.

On some laptops the hardware switch can be quite small to find - check your laptop manual.

share|improve this answer
    
just for information. my wireless was working when i had ubuntu 10.10 earlier. I upgraded to ubuntu 11.10 but then ran into problems. Finally I reinstalled 11.10 32 bit ubuntu using installation cd. since it worked earlier do you still think its a problem of hardware switch. I know of one hardware switch and one fn key switch. Both the switches are on. Please help me out. –  Venkat Kotra Nov 9 '11 at 13:15
add comment
sudo modprobe -r acer-wmi
cd /etc/modprobe.d
sudo nano blacklist.conf

Then add blacklist acer-wmi as a new line at the end of the file.

after doing the above.

rfkill list all

    0: ideapad_wlan: Wireless LAN
        Soft blocked: no
        Hard blocked: no
    1: ideapad_bluetooth: Bluetooth
        Soft blocked: no
        Hard blocked: no
    3: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: yes
    5: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no

but Am not able to enable wireless. The enablewireless text is disabled on the dropdown menu of network connections.

The physical hardblock is still disabled even though the switch is on. This is a problem with bios.

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/577114

you need to reset the bios settings to default.

Press F2 at reboot Press F9 to reset Press F10 to save the reset settings.

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/577114/comments/42

This worked for me. Thanks to @fossfreedom and others. Lenovo ideapad Z570 wireless problem is fixed

share|improve this answer
add comment

protected by Community May 26 '12 at 0:58

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.