Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm having an issue getting dual monitors working for Kubuntu 11.10. I have Asus m4A89 GTD pro/USB3 mother board with integrated Ati HD4290 graphics chip. When I try to enable multiple monitors through the system settings, it says "This module is only for configuring systems with a single desktop spread across multiple monitors. You do not appear to have this configuration."

I had previously attempted to fix this problem with another installation of Ubuntu 11.10, but ended up having to reinstall ubuntu because i messed up the software center dependencies. After I installed Ubuntu the first time, a notification showed up asking me to install an Ati graphics driver. I installed this driver, then restarted, and dual monitors did not work. That was when I went to the ATI site and attempted to install the fglrx driver. When I tried to run the shell script for the fglrx driver, it said i had a previous version of an fglrx driver installed, and needed to remove it in order to install the new one. So I looked up some tutorial on how to remove it and found some apt-get remove command, which i ran. Then I was able to install the new driver. Dual monitors still did not work, and i couldn't use the software center any more because it was corrupted and was unable to repair itself. So i just reinstalled ubuntu, and now i'm trying to go about this the correct way.

Does anyone have this same configuration and which driver works for you?

share|improve this question
add comment

3 Answers 3

Download the lastes ATI drivers from "Restricted Drivers".

Execute the following command to "force the dectection" of your dual screen:

 sudo aticonfig --initial=dual-head

It's also good idea to remove .config/monitors.xml in order to avoid conflicts, so execute the following commande:

rm ~/.config/monitors.xml 

If all went ok you should see an output as in Dai's thread when executing the command (without the Xinerama configuration in my case):

more /etc/X11/xorg.conf

Open "AMD Catalyst Control Center Admin" go to "Display Manager" (mine is in French so am just guessing the English names). You should now be able to see both your screens on the configuration. Go to the "multiple display" tab and select the last option "Desktop with mutiple display or right of display 2" (remember am guessing the names it may be different on your configuration). A promt should pop asking to confirm the setting and restart your system. Restart your system after confirmation.

When logged back, you should have different displays on your screen but the resolution display may be wrong. Go again to "ADM CCC Admin" to ajust your display and position.

Hope it helps.

ATI Mobility Radeon HD 5400 Series
Catalyst Version 11.8

My final "etc/X11/xorg.conf " file:

Section "ServerLayout"
    Identifier     "amdcccle Layout"
    Screen      0  "amdcccle-Screen[2]-0" 0 0
EndSection

Section "Monitor"
    Identifier   "0-LVDS"
    Option      "VendorName" "ATI Proprietary Driver"
    Option      "ModelName" "Generic Autodetecting Monitor"
    Option      "DPMS" "true"
    Option      "PreferredMode" "1366x768"
    Option      "TargetRefresh" "60"
    Option      "Position" "0 0"
    Option      "Rotate" "normal"
    Option      "Disable" "false"
EndSection

Section "Monitor"
    Identifier   "0-CRT2"
    Option      "VendorName" "ATI Proprietary Driver"
    Option      "ModelName" "Generic Autodetecting Monitor"
    Option      "DPMS" "true"
    Option      "PreferredMode" "1600x1200"
    Option      "TargetRefresh" "60"
    Option      "Position" "1366 0"
    Option      "Rotate" "normal"
    Option      "Disable" "false"
EndSection

Section "Device"
    Identifier  "amdcccle-Device[2]-0"
    Driver      "fglrx"
    Option      "Monitor-LVDS" "0-LVDS"
    Option      "Monitor-CRT2" "0-CRT2"
    BusID       "PCI:2:0:0"
EndSection

Section "Device"
    Identifier  "amdcccle-Device[2]-1"
    Driver      "fglrx"
    Option      "Monitor-CRT2" "0-CRT2"
    BusID       "PCI:2:0:0"
    Screen      1
EndSection

Section "Screen"
    Identifier "amdcccle-Screen[2]-0"
    Device     "amdcccle-Device[2]-0"
    DefaultDepth     24
    SubSection "Display"
        Viewport   0 0
        Virtual   2966 2966
        Depth     24
    EndSubSection
EndSection

Section "Screen"
    Identifier "amdcccle-Screen[2]-1"
    Device     "amdcccle-Device[2]-1"
    DefaultDepth     24
    SubSection "Display"
        Viewport   0 0
        Depth     24
    EndSubSection
EndSection
share|improve this answer
add comment

I had no issues with installing the ATI drivers until 11.10. What I ended up doing was to uninstall the previous versions of fglrx as per the ubuntu help site and then running the driver .run file. Instead of installing the driver, let it create distibution specific files and install those.

share|improve this answer
add comment

I got mine working by enabling Xinerama.

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    Screen      1  "Screen1" RightOf "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "1"
EndSection

This is assuming that your monitors are both recognised and listed in the /etc/X11/xorg.conf file.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.