Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Today, after a fresh install, I can't seem to login with my user account.

The Guest account allows me to login, but not my usual account (the one set during install). My account name was used in the past with older installs of Ubuntu. I also have a /home dir that is partitioned. Do I need to delete some settings in the /home or somewhere?

Here are my partitions used: Does anyone see anything wrong with these? Not sure about he / and /boot.

/dev/sda1 ext4 1GB  /boot
/dev/sda5 swap 8GB  swap
/dev/sda6 ext4 20GB /
/dev/sda7 ext4 20GB /usr
/dev/sda8 ext4 20GB /var
/dev/sda9 ext4 20GB /srv
/dev/sda10 ext4 181GB /home (existing - not formatted)

Edit: I noticed it accepts the username/password, but I then see a black screen - then back to the login prompt. Could there be an old nVidia setting in there that is causing the screen to go black? In a previous install I did have nVidia issues - I gave up on that one. Maybe I should try to load the drivers and put the nVidia card back in?

share|improve this question
    
What happens when you try to login? Is it possible you may have set the password incorrectly? –  Anarci Nov 5 '11 at 22:23
    
Sorry, I should have been more clear about that part. It definately gets past the password. It goes to a black screen and then back to the login prompt. –  jjwdesign Nov 5 '11 at 22:28
    
Have you tried unity 2D, it may be a graphics problem. Also try booting into the recovery console. You may be able to fix broken packages and check if you can login at a terminal –  Anarci Nov 5 '11 at 22:32

2 Answers 2

up vote 1 down vote accepted

This trick worked for me...then I wrote the steps in this post:

http://www.computerandyou.net/2011/10/how-to-solve-unable-to-login-into-ubuntu-11-10/

Try it and do tell me if it works for you as well

share|improve this answer
    
Ubuntu Magic! It worked. It fixed my issue. I'm not sure how deleting the Xauthority would help, but it must have removed the setting issue. * At log in screen, press Ctrl+Alt+F1, * Login with your username/password, * ls -Shla | grep “Xauthority”, * sudo mv .Xauthority Xauthority.old, * sudo shutdown -r now –  jjwdesign Nov 6 '11 at 2:23
    
am happy that it worked for you...:) –  abhishek Nov 6 '11 at 9:11

had the same problem with ubuntu 12.10 after trying to change the nvidia driver.

as written in http://www.computerandyou.net/2011/10/how-to-solve-unable-to-login-into-ubuntu-11-10/ this method works:

  • At log in screen, press Ctrl+Alt+F1
  • Login with your username/password
  • ls -Shla | grep “Xauthority” sudo mv .Xauthority Xauthority.old
  • sudo shutdown -r now
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.