Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Is there a way to clear the pop up notifications I get from changing the volume, brightness, dropbox updates, etc...?

Sometimes I have to sit and wait for them to go away so that I can continue to work, as they are blocking something I want to click or look at.

I know this question might seem a little naggy but it does indeed lower my productivity sometimes. I don't mind getting the notificatoins, I do mind not having a option to clear them.

Any idea how I can do that?

Thanks.

P.S. I am using Ubuntu 11.10 (Gnome)

share|improve this question

4 Answers 4

up vote 6 down vote accepted

The package responsible for displaying the notifications is notify-osd Install notify-osd. You can remove it by opening up a terminal and running the following command:

sudo apt-get remove notify-osd

Fair warning: this will permanently disable all notifications.


If you later decide you want the notifications back, you can run the following command:

sudo apt-get install notify-osd
share|improve this answer
1  
Also, don't panic if you get a warning that the package ubuntu-desktop is going to be removed - it is a meta-package. –  Nathan Osman Nov 5 '11 at 18:24
1  
thanks for your response, but I don't want to permanentely remove them. –  nunos Nov 5 '11 at 19:22

Kill the notify-osd program. That'll stop it from notifying until you reboot.

share|improve this answer

In Ubuntu 12.04, you can use NotifyOSDconfig as explained here:

sudo add-apt-repository ppa:leolik/leolik
sudo add-apt-repository ppa:amandeepgrewal/notifyosdconfig
sudo apt-get update
sudo apt-get install notifyosdconfig

Then you can run the program "NotifyOSD Configuration" from Dash Home. Select the option "Close Bubble on Click" and you are done :)

share|improve this answer
    
The http link you mentioned may answer the question certainly , It is recommended to mention complete answer If possible , if not part of the answer here.Thank you. –  AgentCool May 19 '13 at 13:59
    
Jai, I'm new here and didn't get your comment: are you talking to me, or to the one who made the question? If you're talking to me, what am I supposed to do? Thanks. –  Emi May 19 '13 at 20:47
    
please mention answer here , not the link. –  AgentCool May 20 '13 at 1:13
1  
done! hope you like it :) –  Emi May 28 '13 at 21:39

First of all, the notifications are click-through, and should fade when you mouse over them, so they should not make you wait for clicking/seeing something below.

There is also the possibility to temporarily get no notifications except some specific ones like changing the audio volume. Applications like Totem use this while you are viewing a movie full-screen, for example.

But there is no way to "dismiss" them AFAIK.

(This all asumes you are using GNOME with Unity.)

share|improve this answer
1  
I know they are click through but it is still a little hard to read through them, since they don't fade that much, they just blur a little. –  nunos Nov 5 '11 at 19:24
    
It guess it also depends on what is beneath it, but you are right that it might not always be very readable... (I also think they faded more in past versions?) –  JanC Nov 5 '11 at 20:07
    
It might help your productivity to remove some notifications at least: askubuntu.com/questions/67500/… (also you can set them to have a lower timeout, so they go away in 4 secs instead of 10, e.g., in system settings->notifications) –  unhammer Jan 26 '12 at 19:54
    
Also occasionally a program (e.g. qBittorrent) will spam hundreds load of notifications. Then they don't go away for ages. Partly a bug in qBittorrent, but I'd say the problem is more with osd-notify. –  Timmmm Jun 7 '13 at 17:46

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.