Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed Ubuntu 10.04 on my LG R590 laptop, and when I boot it, I can't get my external monitor to work. System->Preferences->Monitors won't recognize it (even when I click Detect monitors), and when I press Fn+F7 - which is my laptop's function key for switching between built-in/external displays - it does nothing.

I found in the internet this article, which says I need to edit my xorg.conf file for this to work, and says that file should be created automatically when I install Ubuntu. However, I can't find it in my /etc/X11/, and this answer says that Ubuntu doesn't need that file anymore so it doesn't create it - though it still uses it if it finds one. It also says that if I have an NVidia card (which I have) I can force Ubuntu to create it by using sudo nvidia-xconfig, but I get a command not found when I try it.

So, is there any other way to make Ubuntu recognize my external screen? Or any way to force Ubuntu to create a xorg.conf file so I can edit it according to that tutorial?

BTW, I don't know if it matters, but I connect my external monitor via HDMI-DVI cable(HDMI side goes in my laptop, DVI side goes the monitor)

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

OK, I managed to solve this all by myself(with some help from the Internet... and a friend who knows some Linux...)

I just had to download and install the NVidia driver, reboot, and than System->Preferences->Monitors will open the NVidia's control panel instead of the default Ubuntu one, and allow me to set everything I need plus it made me an xorg.conf file.

Now the only problem left is how to make it work in terminal mode...

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.