Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I did a fresh install of 11.10 shortly after it was released. My laptop's touchpad (a Synaptics touchpad I believe, laptop is an Asus G53SW) had been acting strangely from the beginning. After receiving an answer to this question, I decided to look for other multi-touch gestures, and came across this page in the Ubuntu Wiki. It turns out all of the weird behavior I had observed (windows getting moved, maximized/restored, or grab handles appearing) corresponds to 3-finger gestures. Whenever any of these behaviors occur, my touchpad will generally stop responding to 1-finger movements (tapping for clicks or dragging to move the cursor) until I click one of the two mouse buttons below the pad, which further reinforces my suspicion that the touchpad is somehow sending out 3-finger gestures at random when I use it.

I decided to try all the gestures out myself to see how the touchpad responds. The only gestures I can get to work consistently are: two-finger drag (scrolling) and three-finger tap (grab handles). Three-finger dragging (move window) works fine half the time, the other half the window jumps around a LOT as I drag it. I also ran into this question while researching the subject. I decided to run geistest to see if my touchpad supported 4 finger gestures in the first place. These were the results: http://pastebin.com/znnnXsA9

So it's clear my touchpad isn't working perfectly. So here's the pertinent questions:

  1. Is there any way to fix this erratic behavior? I'm guessing no, so...
  2. Is there any way to disable the 3-finger gestures specifically? According to this question, probably not, so...
  3. How can I disable multi-touch altogether? How would I re-enable it if I change my mind?

EDIT: Installed Gnome Shell, having no problems with the touchpad. At this point I'm dead sure the problem is with Unity's 3-finger gestures. I'd still like a solution to the issue, as I'm quite partial to Unity.

share|improve this question

1 Answer 1

I'm not able to answer all of your questions, but I can answer #3. If you're using a touchpad on your laptop, you can click on the Power button (upper right-hand corner), and choose "System Settings". Then, click on the Mouse and Touchpad option. In there, click the tab for touchpad, and uncheck the "Enable mouse clicks" option. You can also set the scrolling to Disabled, or Edge Scrolling.

As for the other two questions, you can always try updating to see if that fixes the issues. If you open Software Center, you can search for Synaptiks touchpad management, or touchpad. Install the appropriate application (synaptiks is for KDE, but it should work in Unity as well), and configure the touchpad.

Hope this helps you, and have a great weekend:) Patrick.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.