Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I have "automatic login" activated, the "Unlock the Gnome Keyring" box asks for my password. But this happens three times. There are three boxes asking me for my password. In 10.04 the box appeared one time.

share|improve this question

Make sure you've disabled auto login as per this guide:

Then when you login again & are prompted to unlock keyring, click "Details" & there will be an option to automate the unlocking process.

Repeat for each prompt.

You should now only be prompted the one time at login.

This worked for me, hope it is some help to someone...

share|improve this answer
i had the 3 times prompt and i fixed it by using your advice. thanks! – gourgi Apr 2 '11 at 10:54
For me this option was grayed out :-/ – JochenJung May 13 '11 at 9:05
I had the same problem in 10.04 and 10.10 but now in 11.04 it's gone! :) – Alvar May 24 '11 at 11:09

Take a look at "Passwords and Encryption Keys". A friend of mine had the same problem:

It's possible to create several bundles of keys. However, you have to unlock every single bundle after logging in (and a program tries to access it).

Here's what it should look like: my key-bundle setup

Good luck

share|improve this answer
If you don't find it, use: Alt+F2 then type seahorse. – antivirtel Jul 7 '11 at 21:00

The keyring prompts are because your keyring and logon passwords are different or your system is set to autologon. The fix is to go to "Passwords and Encryption Keys" under System/Preferences right click on Passwords select "Change Password" set it to blank for no password (useful if your system is set to auto logon) or change it to your current logon password.

The e-mail prompts may be some program is trying to check mail at logon. Disable the program or set it to save your password.

share|improve this answer

try deleting your keyring and creating a new one by issuing this command

sudo rm ~/.gnome2/keyrings/*.keyring

Reboot.When you login a box will pop up asking you to create a new keyring. Hope this works.

share|improve this answer
Or rename/move them to somewhere else (to keep a backup, just in case). – JanC Oct 21 '10 at 22:38
Worked for me, thanks – johnc Oct 21 '10 at 23:00
BEWARE: Keyrings contain an encrypted list of passwords; deleting such a keyring will cause loss of any passwords it contains. – Zaz May 6 '11 at 15:55

You could go into "Password and Encryption Keys" in your Control Panel. Right click on the Password: Login put in your current password and then leave the new password blank. This will stop this coming up also.

share|improve this answer
That's not a solution for the problem, but just hides it at best! – JanC Oct 21 '10 at 22:36
Need launchpad bug for that! – Extender Oct 22 '10 at 8:26

I'm not quite sure but I think you should also be able to go to System -> Settings -> Password and Encryption Keys and then delete (right click on them) two of the three keyrings you should see in the list (tab Passwords). This would be sort of a combined solution of Open Help's and Dean Thompson's.

share|improve this answer

I too had several password requests after auto-login (between 3 to around 8). I just deleted my chat accounts and now it only asked once! I know this is not a solution but it could help to pinpoint the problem.

share|improve this answer

Get this patch, apply the patch to gkd-secret-unlock.c in gnome-keyring's source, rebuild the gnome-keyring package and install it. For more details on the bug and patch see Bug 744929 for gnome-keyring.

If you're not familiar with the above process, here is what I did:

  1. apt-get source gnome-keyring
    • Get the source code
  2. patch daemon/dbus/gkd-secret-unlock.c dont-prompt-multiple-times-rebased.patch
    • Apply the patch (you'll need to specify the correct file locations)
  3. dpkg-buildpackage -uc -b
    • Build the package
  4. sudo dpkg -i
    • Install it. Your package name may be different from mine.

Note I'm on version 11.04, so I don't know if the patch will work for 10.10. Both have version 2.92.92 except the number is different after the .is. and I'm not sure what that indicates in versioning.

Thanks to Felix Lawrence for providing the patch backport.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.