Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I started getting the error "Error mounting partition to /media/Date Press S to skip mounting this partition or M to manually mount this partition" at startup.

I haven't found any line changed in the fstab file after the error occured. I have changed "/dev/sda5" with the partition's UUID after the error occured but it didn't help. This is how the fstab file looks like now:

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options> <dump>  <pass>
proc                                       /proc  proc     nodev,noexec,nosuid  0  0
# / was on /dev/sda6 during installation
UUID=2956fd81-0373-4d3d-8fd1-991f2c68b2f3  /      ext4     errors=remount-ro    0  1
# swap was on /dev/sda2 during installation
UUID=265490d1-48c4-40a1-8ddd-df37a44a6ff2  none   swap     sw                   0  0
UUID=0BC8605C581B81ED /media/Date  ntfs-3g  quiet,defaults,rw    0  0

When I try to mount the patition by clicking on it in nautilus I get the error: "Error mounting: mount exited with exit code 1: helper failed with: mount: only root can mount /dev/sda5 on /media/Date"

It can be mounted through gparted, but i can only acces it as root.

share|improve this question

5 Answers 5

You can fix this problem by installing ntfs-3g

In terminal, you type:

sudo apt-get install ntfs-3g

then reboot.

share|improve this answer

This issue is emanating from Windows. It is not granting access due to fragmented files in the NTFS drives. To find solution to that, after trying all what have be provided online,is to do the following:

  1. Restart your system and boot to Windows OS.

  2. Go to your partitioned drives and do a defragment on them.

  3. Restart the system and boot to Ubuntu.

**This will surely solve the problem after RESTARTING the system solution failed, editing fslab failed, running ntfs-config failed and the gparted failed.

share|improve this answer

could you try changing UUID=0BC8605C581B81ED /media/Date ntfs-3g quiet,defaults,rw 0 0

to UUID=0BC8605C581B81ED /media/Date ntfs-3g defaults,uid=1000 0 0

Do tell me if it works...

share|improve this answer
    
I commented the line I had and pasted the one you suggested under. I still get the error and can only mount the partition as root. –  Dan Nicolescu Nov 5 '11 at 10:18

this is what I have for my entire fstab, and it works, including bind mounting the NFTS mounts. I created a group called ntfs and added my user ID to that group, that way I could add multiple users to the group without having to change my fstab.

#
# <file system>                 <mount point>       <type>  <options>                   <dump>  <pass>
proc                            /proc               proc    nodev,noexec,nosuid         0       0
# / was on /dev/sda3 during installation
UUID=1754407b-2d9a-4fcb-9be4-121fbed4c51f   /                   ext4    errors=remount-ro       0       1
# /home was on /dev/sda4 during installation
UUID=aec52c00-274e-423d-b977-a13ee8ad72e5   /home               ext4    defaults                0       2
# /home/user/VM was on /dev/sdc1 during installation
UUID=549E60579E6033A0               /home/user/VM   ntfs    defaults,umask=002,gid=1002     0       0
# /home/user/Videos was on /dev/sdb1 during installation
UUID=30CE4E4DCE4E0C12               /home/user/Videos   ntfs    defaults,umask=002,gid=1002     0       0
# /mnt/1TB-ext was on /dev/sdf1 during installation
UUID=8C187D90187D79D2               /mnt/1TB-ext            ntfs    defaults,umask=006,gid=1002     0       0
# /mnt/2TB was on /dev/sde2 during installation
UUID=B29E5A379E59F3F7               /mnt/2TB            ntfs    defaults,umask=002,gid=1002     0       0
# /mnt/storage was on /dev/sdd1 during installation
UUID=358D3F9345048F79               /mnt/storage        ntfs    defaults,umask=002,gid=1003     0       0
# /backup was on /dev/sdf1 during installation
UUID=4fca1f62-dcec-458e-a111-29d22e801a9b   /backup         ext4    defaults            0   0
#     /mnt/windows was on /dev/sda7 during installation
UUID=0083CA6A5E67A77F               /mnt/windows        ntfs    defaults,umask=006,gid=1002     0       0
# swap was on /dev/sda6 during installation
UUID=935c28d7-c12b-4669-b5c2-9129c5315850   none                swap    sw                      0       0

# bind mounts
/mnt/storage/music              /home/user/Music    none    defaults,bind,umask=002     0   0
/mnt/storage/music              /home/user2/Music   none    defaults,bind,umask=002     0   0
/mnt/storage/Downloads              /home/user/Downloads    none    defaults,bind,umask=002     0   0
/mnt/2TB/TV                 /home/user/Videos/TV    none    defaults,bind,umask=002     0   0
/mnt/2TB/Pictures               /home/user/Pictures none    defaults,bind,umask=002     0   0
/mnt/storage/drivers                /home/user/Downloads/drivers    none    defaults,bind,umask=002 0   0
share|improve this answer
    
I didn't know about this binding method, it seemes pretty useful, thank you. I tried making something like this 'UUID=0BC8605C581B81ED /mnt/Date defaults umask=002 gid=1003 0 0 /mnt/Date /home/user/Date none defaults bind umask=002 0 0' I actualy copied the attributes from your fstab and made a similar binding, but it didn't change anything, unfortunately. Now I get "Error mounting /mnt/Date." –  Dan Nicolescu Nov 5 '11 at 10:39

well, two applicationcan help you to completely configure your ntfs drives.

First. Ntfs Configuaration tool

install using

sudo apt-get install ntfs-config

it will help you to make read-only or write enabled ntfs drives...

Second is Storage Device Manager

sudo apt-get install pysdm

This helps you to manage fstab files graphically.......means auto-mount option is available.

All the best from RJK

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.