Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Ubuntu 11.10, kernel 3.0.0.13. Netbook medion AKOYA 1210. There is no sounds comming out the headphones. I have to go in the sound applet menu and switch off and on the sound card. After that, sound come out of the headphones.

Is it a bug ? Note I never encountered this issue since Ubuntu 10.04.

share|improve this question
    
You could try to update your kernel. If you open a console and type in sudo apt-get update && sudo apt-get dist-upgrade. This will update other software as well. –  marto Apr 5 '12 at 18:40
add comment

3 Answers

This should work

aplay -l

The output should include the sound card number (ex. "card 1")

then run:

alsamixer -c 1 (replace "1" with the number you got in previous command)

In alsamixer, turn the "speaker" volume up.

If you got sound, save the mixer state with:

sudo alsactl store 1

share|improve this answer
add comment

Under Volume -> Sound Settings,

Did you check Connector, which can be found at the bottom of the window on 12.04?

Sometimes, it does not change automatically.

share|improve this answer
add comment

Thought i'd supplement @erdemkeren answer with screenshots:

Visit sound settings

Make sure to visit sound settings (click on the sound volume icon in the top right): enter image description here

So sometimes you have to click on the orange box that i've shown below: enter image description here


Select your connect

Clicking on the connector will reveal a box with options. Most likely your best bet is the analog headphones. You may have other options as well. You may also have to switch your sound output device (Choose a device for sound output:

enter image description here

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.