Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have looked for answers to this but have not found anything. People have similar problems but mostly with getting the subwoofer to work at all.

I got the subwoofer to work by editing the /etc/modprobe.d/alsa-base.conf file and adding options snd-hda-intel model=ref.

When I plug in my headphones, the main speakers turn off but the subwoofer still has sound coming through it. The output is selected automatically in sound preferences and is set to headphones when they are plugged in. I also have tried muting the main speakers, which in turn mutes the subwoofer, before plugging in the headphones as they seem to have two different volume controls, but as soon as the headphones are plugged in, the subwoofer has sound coming out of it.

I am running Ubuntu 11.10 64 bit on HP dv7- 4285dx.

I am able to just not have the subwoofer on but since I have gotten it to work I would like to keep it around and not have to change a config file every time I want to plug in my headphones.

Any ideas or suggestions would be greatly appreciated.

Thanks

share|improve this question

closed as too localized by fossfreedom Jan 12 '13 at 8:19

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
can you manually mute the subwoofer-channel in alsamixer? It's not a fix, but at least you can use the headphones –  marto Apr 5 '12 at 18:12
    
This question appears to be abandoned and unanswered, could you perhaps add more detail to your question? If this question no longer applies then you can either delete it or answer it yourself if you've solved the problem. This is to help with the Ask Ubuntu Clean Up. If you feel this question is not abandoned, please flag the question explaining that. :) –  Seth Jan 12 '13 at 4:10

1 Answer 1

Have a look at the config file here:

/usr/share/pulseaudio/alsa-mixer/paths/analog-output-headphones.conf

[Element LFE]
switch = off
volume = off
share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.