Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Gnome Classic defaults to using metacity (at least, for me). When I activate compiz (compiz --replace), the unity panel and launcher show up.

This is due to Unity being a compiz plugin.

Is there any way I can get compiz to use a different profile for Unity (w/the Unity plugin on) and another for Gnome Classic (w/the Unity plugin off)? Even though I would prefer to keep both (for support reasons), should I give up on GNOME Classic and just hack the hell out of my Unity login's compiz profile?

share|improve this question

1 Answer 1

up vote 3 down vote accepted

There are 2 different profiles in a fresh install - the unity & the default profile

The default profile by default doesn't have the Unity plugin enabled & uses the 'static application switcher', probably a few other diff.'s

At some point you may have switched to using the 'default' profile while logging into Ubuntu (unity-3d) & enabled unity, ect.

You may be able to set all back with a gconftool command but try this 1st. -

Login to Ubuntu (unity-3d) & then open this file

gedit ~/.config/compiz-1/compizconfig/config

If it has this section in it then remove [general_ubuntu] & all below it, save. (or just remove all from the file & save as an empty file

[general_ubuntu]
profile =

Then open a terminal & run ccsm, it should show on line 5

Profile     : unity

If so then your Ubuntu login is on the unity profile where it belongs

Then log out & in to Classic - start compiz if need be, then run ccsm from there. Line 5 should show

Profile     : default

If so then any ccsm changes made in either Classic or Ubuntu logins will not affect the other login

Edit:

The moment you click on "Preferences" in ccsm while in the Ubuntu session you will be switched from the 'unity' profile to the 'default' profile.

Sometimes this causes a hang, other times if you wait the desktop (control) will return, usually sans unity.

Here is a bug I have on this unfortunate occurence

https://bugs.launchpad.net/ubuntu/+source/compizconfig-settings-manager/+bug/880679

share|improve this answer
    
I did change profile. The selected profile name consisted of odd looking boxes and lines - not a language, just gibberish. So, I deleted it and was rudely brought to the lightdm login screen. Logged back in, ran CCSM, and the Profile was still there - this time consisting of new gibberish. Another try deleting it and again crashed to login. Logged back in, ran CCSM, and the profile was gone this time. I imported my 10.10 saved profile and nothing happened; so, I rebuilt Default for (Gnome Classic) from what I could remember of it. –  user32358 Nov 5 '11 at 4:24
    
I will check out your instructions, modify then to account for the fact that 'unity' profile is gone (I will recreate it), and hopefully I can get a unity profile working, again. TYVM –  user32358 Nov 5 '11 at 4:24
    
Logged back in on "Ubuntu" > cleared the file you mentioned as it did contain the bad info > compiz (or something) noticed the changed file and my desktop crashed back to lightdm's login screen > logged back in on "Ubuntu" > Perfect! Might have ran a unity --reset at some point, too - but, I don't think it mattered. –  user32358 Nov 5 '11 at 6:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.