Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

lspci gives me these two devices:

$ lspci | grep Audio
00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 05)
02:00.1 Audio device: ATI Technologies Inc RV710/730

There are two devices listed in System Settings|Sound|Output:

  • RV710/730 Digital Stereo (HDMI)
  • Internal Audio Analog Stereo

And finally, the are not muted!

Also, when I run an application that accesses the sound card, I can see it in the Applications tab.

Any ideas?

share|improve this question

3 Answers 3

up vote 2 down vote accepted

It seems that the new kernel update (3.0.0-13) solved the problem.

share|improve this answer

I am depending on a previous Launchpad q/a (last answer) [1] and suggest compiling Alsa. But instead of grabbing Realtek drivers (same as Alsa) just download latest files via alsa-project.org [2]. You need to download just alsa-driver, alsa-lib and alsa-utils packages. Pick latest ones which has 1.0.24 version. After that just compile the packages as explained there.

If you get an error about panelw library while compiling alsa-utils, just change the configure step as this:

./configure --with-curses=ncurses

[1] https://answers.launchpad.net/ubuntu/+source/alsa-driver/+question/93857
[2] http://alsa-project.org/main/index.php/Download

share|improve this answer
    
I couldn't compile alsa-driver in 11.10. I am getting this error message: ioctl32_new.c:23:28: fatal error: linux/smp_lock.h: No such file or directory –  Mohammad Moghimi Nov 6 '11 at 1:11
    
This error occurs because of removal of BKL: kerneltrap.org/Linux/Removing_the_Big_Kernel_Lock That means our kernel is too update for Alsa packages. With those packages we can fix somehow (dirty way) smp_lock error but there will be others. So, grab the latest snapshots here: alsa-project.org/snapshot Compiling is a bit tricky. First, install patch and libncurses5-dev directly. Then use this sudo apt-get install xmlto --no-install-recommends to install just xmlto. When compiling alsa-utils use this: ./configure --with-curses=ncurses --disable-nls –  heartsmagic Nov 7 '11 at 1:18
    
Thanks heartsmagic for the help. I could make alsa-driver and alsa-lib. When I'm making alsa-utils, I'm getting this: checking for snd_ctl_elem_add_enumerated... no configure: error: No user enum control support in alsa-lib –  Mohammad Moghimi Nov 10 '11 at 9:35
    
Have you successfully installed alsa-driver and alsa-lib after compiling them? I think, this error occures because of no installation of the new packages. –  heartsmagic Nov 10 '11 at 10:50
    
Yes, I installed both. I think I did "make install" too. I'll check again. –  Mohammad Moghimi Nov 12 '11 at 7:44

I had the same problem. I solved reinstalling alsa modules sudo apt-get install --reinstall linux-image-$(uname -r)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.