Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I noticed that the grid plugin wasn't restoring windows to the original size. So I went to ccsm to try to tweak the options to get the desired results. I tried disabling "snap windows to their original size", to then renable it and see if it worked. However, when I disabled it, the windows lost their title bars, the panel, dash and launcher were gone. I usually run "unity --replace" when this sort of thing happens, but because there was no dash I couldn't run any commands. So I pressed Ctrl+Alt+F6b (not sure what this is callled) and ran "unity --replace" from there. However unity wasn't restored and now I only have a top bar with only the appmenu and no launcher or dash. I tried to logout and reboot but neither worked. Gnome Shell works, though. Please help me, I don't want to reinstall the OS or something to solve this issue.

share|improve this question
up vote 7 down vote accepted

Try running unity --reset from a terminal.

share|improve this answer
Thank you, that solved it! – DeoxNa Nov 5 '11 at 1:38

If you delete the compiz config settings, they will be reset once you log in again. Try executing the following command, one-by-one:

rm -rf $HOME/.compiz-1  
rm -rf $HOME/.compiz/  
rm -rf $HOME/.config/compiz-1  
rm -rf $HOME/.gconf/apps/compiz-1  
rm -rf $HOME/.gconf/apps/compizconfig-1  
rm -rf $HOME/.cache/compizconfig-1  
share|improve this answer
To avoid accidentally putting a space before or after the first slash, which would delete all the files in your home directory including all your documents, I'd suggest instead cding to $HOME and then doing rm on the relative paths: cd; rm -rf .compiz-1 .compiz .config/compiz-1 .gconf/apps/compiz-1 .gconf/apps/compizconfig-1 .cache/compizconfig-1 – Eliah Kagan Jul 16 '12 at 18:38

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.