Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have tried to install the Beta version of Flash using the Firefox plugin Flash-Aid with no luck. The Beta version right now is the 11.2 and I wanted to test it how it changed in performance wise but I seen to find it difficult to install it.

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

First of all, uninstall any Flash version on your system. Download the suitable (32bit or 64bit) installer here: http://labs.adobe.com/downloads/flashplayer11-2.html

Extract the archive and put libflashplayer.so file in /usr/lib/mozilla/plugins for system wide:

sudo cp libflashplayer.so /usr/lib/mozilla/plugins

For user only:

mkdir ~/.mozilla/plugins # If there is not
cp libflashplayer.so ~/.mozilla/plugins
share|improve this answer
    
Somehow is not working. Firefox, even after rebooting still reads 11.0.1.152 –  Luis Alvarado Nov 6 '11 at 17:01
    
Ok, I tried it myself. Unfortunately, /usr/lib/adobe-flashplugin directory for system wide solution does not work for me. Instead, /usr/lib/mozilla/plugins works. Also ~/.mozilla/plugins is also working here. So, first uninstall flashplugin-downloader and flashplugin-installer packages, close Firefox and just copy the file to ~/.mozilla/plugins directory. You can check via about:plugins. But, it is not stable. For example on Youtube I see just mixed colours. On dailymotion and a few other sites it is working though. –  heartsmagic Nov 6 '11 at 23:41
    
Follow your comment and yes it worked. The actual Beta usage was for performance and testing and as you say, it is very unstable, crashes a lot and has several bugs because still in Beta. Tested in several sites as you did. The overall performance is almost the same as 11.0. Thanks again heartsmagic. –  Luis Alvarado Nov 7 '11 at 0:40
    
You're welcome. Btw, I fixed the wrong directory name for system wide Flash in my answer. –  heartsmagic Nov 7 '11 at 0:45
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.