Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My laptop seems to get very hot when running with Ubuntu. The vents arent blocked and its got plenty of clear airflow when in use. Its noticeably hotter running ubuntu than it is running windows.

I havent noticed any adverse hardware problems yet, but if it does get really hot it seems to become very slow.

  • is this likely to be due to ubuntu or just coincidental?
  • If it is Ubuntu is there anything i can do about it?

Its an Acer 5740g with an i3 2310m.

EDIT

To add further detail, im running 11.10 x64 and the fans seem to run pretty much constantly

share|improve this question
    
I guess u should run 'top' for a while and notice if anything is eating plenty of CPU or RAM and then let users here know about it so they can help better –  wisemonkey Nov 4 '11 at 21:57
    
Are you hearing the fan (if any) being used? –  Danny Staple Nov 4 '11 at 23:04
    
Do you have lm-sensors installed and can you try running sensors-detect? And do you run Natty or Oneiric? –  elmicha Nov 4 '11 at 23:13
    
I have some sort of problem and saw that adobe flash is making my acer laptop crashing due to getting to hot. –  Rens Nov 5 '11 at 9:19
1  
I have the same issue and have been told that there is an issue with the Linux kernel when using Intel processors. Hope they solve it by 12.04 because I stuck with Windows 7 right now. Ubuntu is just too hot to use in 11.10 –  Mysterio Nov 5 '11 at 14:17
show 1 more comment

4 Answers 4

It is quite possible that you have an ACPI (power saving) incompatibility. You do not mention which version of Ubuntu you have; try with the latest.

You can try FWTS, which is a firmware and powersaving (ACPI) tool, https://wiki.ubuntu.com/Kernel/Reference/fwts It should help you identify what exactly is not working well.

share|improve this answer
    
I use Ubuntu 14.04 meet the same problem with my laptop ASUS VX32VD –  Casper Li Jun 8 at 15:39
add comment

You could try to open the terminal, then $sudo gedit /etc/default/grub and in the line that says:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

change it for:

GRUB_CMDLINE_LINUX_DEFAULT="acpi_osi=Linux quiet splash"

then save and restart. I hope this solve the problem.

share|improve this answer
add comment

The overheating problem could happen due to the graphics card. Under Windows there is the so called Optimus technology, when you don't play games the laptop just uses the integrated Intel HD for the simple stuff.

I believe that Ubuntu doesn't have that kind of technology yet so it uses the graphics card all the time. What you could do to solve your problem is find a program that acts like Nvidia Pptimus technology.

A quick search lead me to the Bumblebee project.

I didnt try this yet, so I can't guarantee anything. If someone knows/tries if this method works or if the above info is true please confirm, thanks!

share|improve this answer
1  
I've seen a lot of discussion on Bumblebee. I've yet to buy a laptop with Optimus yet because of this reason. The main issue with Bumblebee (from my last time researching it) is that it runs 100% on Intel unless explicitly invoked to use nVidia. So, if you wanted to run a program with the nVidia card, you'd have to do something like '[bumblebee command] alien-arena' –  Githlar Oct 13 '12 at 5:54
add comment

If you have Nvidia optimus try installing the new beta version of Nvidia 319.12 with bumblebee.

sudo apt-get remove bumblebee-nvidia nvidia-current nvidia-settings

sudo apt-get install bumblebee-nvidia nvidia-319 nvidia-settings-319

Link http://orkultus.wordpress.com/2013/04/20/how-to-nvidia-319-12-drivers-in-ubuntu-based-systems-with-bumblebee/

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.