Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a monitor with a default resolution of 1920x1080 and have it set up with a second monitor with a default res of 1280x1024. However, my graphics card (ATI 2900Pro) states its max res to be 2560x1600, and ubuntu will not allow both displays combined to exceed this resolution. Is this likely to be hardware limited? Or can this maximum resolution be overridden in Ubuntu somewhere?

*Edit - Further info requested.

I have the proprietary ATI CCC (and drivers) installed, but this does not allow me to configure the resolution.

I am configuring the resolution using the Displays control panel in Ubuntu.

I have also tried manually editing the xorg.conf. However, whatever I do the system seems to realise that my card only supports the lower resolution and it ends up overlapping the two displays till they meet that resolution.

share|improve this question

2 Answers 2

You need to state:

  • which driver you are using (Open source or Proprietary)
  • which tool(s) you are using to configure your driver

But, as a general guide,

if your graphics card says that it will support 2560x1600 and yet the total "displayable" resolution that you want to display exceeds that then there is probably not much hope.

You may have some mileage experimenting with your /etc/X11/xorg.conf, specifying a suitable virtual area to match the desired total resolution, but I would expect this particular approach to work best with a dual display featuring consistent resolutions across both monitors.

Note that if using the proprietary driver, you can generate a suitable Xorg.conf on the commandline using the "aticonfig" command.

I found this to be more reliable than using the gui tool which crashed out all of the time.

Running the aticonfig command generated the following Xorg.conf for one of my machines running oneric ocelot:

(Hint 1: please make sure the driver you state in Xorg.conf is installed before writing it into Xorg.conf, else your X-Server most likely won't start.)

(Hint 2: Xorg.conf might not exist on your system. You can still create one and it will be used, but its settings might be overwritten by configurations made in the files in the folder /etc/X11/xorg.conf.d/ )

(Hint 3: please keep a copy of your old xorg.conf prior to editing the file)

Section "ServerLayout"
    Identifier     "aticonfig Layout"
    Screen      0  "aticonfig-Screen[0]-0" 0 0
    Screen         "aticonfig-Screen[0]-1" LeftOf "aticonfig-Screen[0]-0"
EndSection

Section "Module"
EndSection

Section "ServerFlags"
    Option      "Xinerama" "on"
EndSection

Section "Monitor"
    Identifier   "aticonfig-Monitor[0]-0"
    Option      "VendorName" "ATI Proprietary Driver"
    Option      "ModelName" "Generic Autodetecting Monitor"
    Option      "DPMS" "true"
EndSection

Section "Monitor"
    Identifier   "aticonfig-Monitor[0]-1"
    Option      "VendorName" "ATI Proprietary Driver"
    Option      "ModelName" "Generic Autodetecting Monitor"
    Option      "DPMS" "true"
EndSection

Section "Device"
    Identifier  "aticonfig-Device[0]-0"
    Driver      "fglrx"
    BusID       "PCI:1:0:0"
EndSection

Section "Device"
    Identifier  "aticonfig-Device[0]-1"
    Driver      "fglrx"
    BusID       "PCI:1:0:0"
    Screen      1
EndSection

Section "Screen"
    Identifier "aticonfig-Screen[0]-0"
    Device     "aticonfig-Device[0]-0"
    Monitor    "aticonfig-Monitor[0]-0"
    DefaultDepth     24
    SubSection "Display"
        Viewport   0 0
        Depth     24
    EndSubSection
EndSection

Section "Screen"
    Identifier "aticonfig-Screen[0]-1"
    Device     "aticonfig-Device[0]-1"
    Monitor    "aticonfig-Monitor[0]-1"
    DefaultDepth     24
    SubSection "Display"
        Viewport   0 0
        Depth     24
    EndSubSection
EndSection

Good luck.

share|improve this answer
    
Thanks, I've edited my post with further information, I suspect its limited somewhere in the drivers. Might be easier to pick up a second cheap card and run the second monitor through that. –  grrrrrrrrrrrrr Nov 4 '11 at 19:58

Had the same problem and the solution was simple once I was able to track it down

First remove our current xorg.conf file:

sudo rm /etc/X11/xorg.conf

Then recreate a new one based on your current hardware config

aticonfig −−initial

Then, run the ati control panel with the appropriate permissions and update your settings:

sudo amdcccle
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.