Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

On Ubuntu (every version I tried since about ~2009 or 2008), the sound quality is noticeably different than on Windows XP, regardless of what program I use for playback (YouTube, listening to MP3s, Spotify, etc.)

The sound is clearly worse and less natural on Ubuntu: my laptop sounds somewhat like a tin can (for lack of a better way to describe it), and when the volume gets even moderately high, the laptop case starts to resonate (which is just awful, and never happens on Windows XP, not even at the highest volume).

Please note---this is not a subjective quality difference: the laptop case will resonate on Ubuntu as soon as the volume gets turned up to mid-level. It does not on Windows even at maximum volume.

Some extra info about my setup

The computer is a Dell Inspiron 6000, with "SigmaTel C Major Audio" sound. On Windows I'm using the default drivers from Dell, I didn't modify any settings, and I checked that no extra sound processing is enabled (e.g. 3D or bass boost or whatever that's available on some computers). On Ubuntu 11.10 I'm also using the defaults. There's no noticeable difference in the sound volume of Ubuntu and WinXP.

Questions

  1. Why is there a difference in sound quality?

    Doesn't the audio data that is sent by programs get "rendered" to speakers as-is? Is there some extra processing, perhaps to compensate for the characteristics of the speakers or laptop case, akin to colour-management?

  2. What can I do to fix this, and make Ubuntu sound as natural as Windows XP on my laptop?

share|improve this question
    
If you're feeling ambitious you can try disassembling the laptop enough to get the speakers loose, then fill any cracks with Blu-tack or any similar product. I do this with my mobile phone which is quite a bit easer than doing it with a lappy. Works well, though. No more resonation from the case. –  Tom Brossman Feb 27 '12 at 21:06
    
@Tom Thanks for the suggestion, but I'd rather not take it apart---I am still hoping for a software based solution. I suspected something might be wrong with the driver on Ubuntu. –  Szabolcs Feb 27 '12 at 21:14
    
For diagnostics have you tried a Live CD of Ubuntu or a different distro ie: Puppy just to "SEE" if there was truly a difference? I cannot say if resonant frequencies differ in windows 7 vs Ubuntu but I suppose anything is possible. One more thing to consider is the difference between external speakers attached? Got to think about that! –  Ringtail Feb 27 '12 at 21:20
    
I've got good results in the past with checking that any pre-amplification is lowered, but I don't know how to do this in 11.10, it 'just works'. Maybe try installing Pavucontrol from the Software Center and see if it can reduce the overmodulation. Out of ideas now, good luck... –  Tom Brossman Feb 27 '12 at 21:22
    
@Tom "pre-amplification" <-- what is that? Is it a software-based (digital) amplification? I don't think WinXP has that, so maybe it could be the source of the trouble. I'll google for it. –  Szabolcs Feb 27 '12 at 21:28

7 Answers 7

up vote 4 down vote accepted

The same thing happened to me when I was using Ubuntu for the first time. The reason for me was that Ubuntu had the volume of speakers set to a too high value. Solving this problem is very easy:

  • Using the sound indicator, open Sound Settings and set the sound volume slider at "unamplified", as shown in the image:

sound control panel

I hope this solves the problem.

share|improve this answer
    
I think you may be right about this! –  Szabolcs Apr 21 '12 at 10:50
    
@Szabolcs have you tried it did it work –  user49557 Apr 22 '12 at 12:15
    
Give me a bit more time. If it turns out to be the solution, I'll accept. –  Szabolcs Apr 22 '12 at 20:13
    
This didn't help me :( –  Patryk Aug 28 '12 at 21:07
    
@Patryk please ask a new and put all your information about your sound settings and paste the question URL here i will be happy to help you –  user49557 Aug 30 '12 at 10:20

I have Ubuntu 14.04 on Macbook Pro 9,1. I solved the issue by going to 'System Settings'--> 'Sound' And selecting "Speakers: Built-in Audio" in 'Play sound through' option correct option --> Speakers: Built-in Audio . Originally 'Analog output' had been selected. That instantly fixed my sound problems and gave a crisper sound.

share|improve this answer

I have noticed the same audio discrepancy that you have.

I can't remember the name of it at the moment (haven't used Windows in a long time) but I do think there is an audio processor that enhances the audio on Windows. I remember seeing something in the control panel about it. Then again, maybe I'm crazy. :-P

If you don't see anything that stands out in the control panel, run alsamixer on Ubuntu, and check your levels that way.

Good luck!

share|improve this answer
    
Thanks for the comment---I am certain there is no special audio processing turned on on Windows in this case. I made sure everything is off. –  Szabolcs Apr 21 '12 at 10:51

You could try Open Sound System (OSSv4) with production quality enabled in the ossxmix. Unfortunately this requiers building it from source and also removing ALSA, PulseAudio from your Ubuntu and setting applications backends to OSSv4.

You should post the output of lspci -v command (run it in terminal) for audio device section. When you will know what's your soundcard then you can check if it is supported by Open Sound System.

Ubuntu community documentation regarding OpenSound has commands for removing ALSA (reboot requiered) and of course installation of OSSv4 (including compiling from source). There is also the official guide regarding that process. Before you start the compilation open up software-properties-gtk application as root and check the source code on the first tab. Then update your software sources and run this command:

sudo apt-get build-dep oss4-base

You should change configure script GRC_MAX_QUALITY=3 to GRC_MAX_QUALITY=6 that's for production quality resampler. Know you can build the .deb package.

When all that is done than it's time for configuring applications. You can also emulate ALSA for applications that doesn't support OSSv4 edit /etc/asound.conf or .asoundrc as per instructions on Arch Linux OSSv4 Wiki.

share|improve this answer
    
Open Sound System is definitely superior in terms of sound quality, but unfortunately you may have problems with recording. I can't figured it out on my machine. –  Mateusz Stachowski Feb 29 '12 at 19:32
1  
What exactly do you mean by poor sound quality attribute to PulseAudio and ALSA? Can you backup your claims? –  zetah Feb 29 '12 at 19:45
    
That's what I think when comparing PA and ALSA to OSSv4 with production quality resampler enabled. Open Sound System just sounds much, much better to me (and many others). –  Mateusz Stachowski Feb 29 '12 at 20:52
    
Thinking is not enough. You have to do an ABX test to be taken seriously. Please revisit your answer (together with your previous answer, which you duplicate) and remove such claims as misleading. Something else is faulty in your audio pipeline and you better find what, instead accusing something you don't understand –  zetah Feb 29 '12 at 21:07
    
What could cause the difference? What I still don't understand is why the sound data output by programs isn't sent to the hardware as-is, and what sort of processing happens before it reaches the sound card. I Googled a bit about ALSA and OSSv4 and I found that OSS4 has superior mixing. But if only one program is outputting, then I suppose the mixer should introduce minimal to no distortions. Regardless, I'll try to switch ALSA to OSSv4, just to see if it changes anything. I somehow doubt that the mixer alone could have such a huge impact as what I am hearing, but ... –  Szabolcs Mar 1 '12 at 9:42

Have you tried installing alsa-hda-dkms from the ppa:ubuntu-audio-dev/alsa-daily repository?

Worked for me when my laptop would start distorting like a tin-can.

share|improve this answer

Please check your mixer settings, I have a totally different experience, in Windows 7, my netbook sounds muted whereas in Ubuntu, it comes alive with more imaging.

share|improve this answer
    
Can you be more specific about what settings are you referring to? I'd prefer to turn off any pre-processing of the sound data before it is output. I believe I managed to do this in Windows XP. How can I do this in Ubuntu as well? –  Szabolcs Feb 28 '12 at 9:44

In Ubuntu, have you tried switching the '3D' acceleration setting of the sound card? It might have defaulted to the 3D setting which may have boosted certain frequencies to add a to the stereo imaging of the laptop speakers. How does it sound with headphones when you compare it in Windows?

share|improve this answer
    
Can you give some hints on where to find this setting? I was unable to find it in the sound settings dialog on 11.10. –  Szabolcs Feb 28 '12 at 8:38
    
@Szabolcs I don't think this setting exists, sounds like a WIndows Media Player thing. –  Tom Brossman Feb 28 '12 at 9:03
    
You can install alsa mixer from the software center and access your sound card settings. –  rylhunt Feb 28 '12 at 15:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.