Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using Ubuntu 11.10, and whenever I enter the recovery menu, my keyboard freezes and I can't make any selections. I have tried using GRUB_PRELOAD_MODULES="usb usb_keyboard" but this doesn't help at all. The keyboard works in the BIOS screen and in Grub (i can select an OS, write to the command line, etc.) but as soon as i get to the recovery menu it stops working. If i had the numlock on it will stay lit and i cannot turn it off, if that helps

share|improve this question

closed as off topic by Marco Ceppi Feb 3 '12 at 0:47

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

    
I have the same problem with my Apple USB keyboard. There is a bug report in Launchpad about this problem: bugs.launchpad.net/ubuntu/+source/friendly-recovery/+bug/203385 –  August Karlstrom Nov 8 '11 at 20:05
    
This question should instead be filed as a bug report, thanks! Instructions here. –  Jorge Castro Feb 3 '12 at 0:32

2 Answers 2

I had the same issue and finally got it resolved. I had to unplug all my usb devices besides the keyboard (maybe there was just one that caused the issue, but I didn't want to try all possibilities). I also had to add 'acpi=off nohz=off' to my boot line in grub (hit 'e' in grub while the recovery mode is selected to change the boot line).

share|improve this answer
    
thanks, i'll try this next time i boot! –  Blanko2 Nov 8 '11 at 11:50
    
I tried only the code and it didn't fix it for me (I didn't try removing all of my other USB cords - maybe that would have solved it) –  Tal Galili Nov 18 '11 at 9:06

I had the same issue today, and with Johannes' answer was able to solve it - unplugging all USB devices except the keyboard worked.

Note though - when I first tried adding the suggested 'acpi=off nohz=off' to the boot line in grub, the keyboard was still non-responsive in recovery mode.

Trying again but NOT adding 'acpi=off nohz=off' did work.

Also, tried various combinations of USB devices (mouse, keyboard, external USB HD, ext USB hub on monitor), and the only combination that worked was "keyboard only".

Also tried adding/removing devices when the Recovery Menu was 'frozen' and it displayed alerts that devices were added or removed (always device 2 though).

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.