Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed uswsusp module with 'sudo apt-get install uswsusp'. Now I am trying to replace the default hibernate method (as launched from the menu) with s2disk. I found information that I am to edit this file:

/usr/lib/hal/scripts/linux/hal-system-power-suspend-linux

Unfortunately the path '/usr/lib/hal' does not exist in my system. Also, the directory '/etc/pm/config.d/' exists, but is empty, and creating there a file '00_sleep-module' did not help. Please help.

share|improve this question
add comment

3 Answers

You can create a file called module in /etc/pm/config.d/module if not already there and add

SLEEP_MODULE=uswsusp

inorder to work with pm-utils

I think you should also go through the configuration part given in the link below.

Source

share|improve this answer
    
I'm sorry, it didn't work out, even though I changed privileges of the file to 755 and restarted the machine to pick up changes. The most annoying feature of the old hibernate is that it asks for password on resume. The link does not provide configuration instruction. –  Wiktor Nizio Nov 5 '11 at 5:31
    
All settings in /etc/pm/config.d/module, /etc/pm/config.d/config and even /usr/lib/pm-utils/defaults seem to be ignored. I might ask another (more specific) question or report a bug if it continues this way. –  Wiktor Nizio Nov 5 '11 at 7:12
add comment

After reinstalling 11.10 from scratch, s2disk is the default option.

share|improve this answer
add comment

Thanks !! A lot, that worked perfect. I was able to get s2disk to hibernate my Toshiba C640, but not restore it. By updating /etc/pm/config.d/00sleep_module and purging cryptsetup as per post on Ask Ubuntu , things started working well.

Although waking from hibernate Grub 2 looks like something is wrong as it is stuck on background for few seconds. Maybe its just grub or large 4 GB ram snapshot being loaded from disk. I will have to check.

Also, my LAN connection came back. I had serious doubts about it, since I had to custom compile Atheros Fast Ethernet card module into Kernel.

I am using kernel 3.2.0-27-generic with Ubuntu 12.04 LTs on Toshiba Satellite C640 Hardware. Steps I have followed

sudo nano /etc/pm/config.d/00sleep_module

If you never touched this file OOTB it should be entirely commented. Please read it entirely. Add following line to end of file

SLEEP_MODULE="uswsusp"

Finally purge cryptsetup, I am not sure about this step, it may or may not help

sudo apt-get purge cryptsetup
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.