Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed Ubuntu to my hard drive using Wubi. The installation seemed to be successful; however, after rebooting my PC I am not brought to a boot menu, and Windows just starts normally. When I manually force my computer to a boot menu, Ubuntu is not listed.

share|improve this question
    
Which version of Windows were you installing in? –  WarriorIng64 Nov 4 '11 at 1:58
    
I'm using Windows XP –  cake Nov 4 '11 at 2:09
add comment

1 Answer

For XP, right click My Computer, click on Properties, click the Advanced tab, Startup & Recovery settings.

Make sure that the Time to display operating systems is 10.

If the timeout is not zero, then in rare cases there is a line missing from the end of the C:\boot.ini required to boot Ubuntu: C:\wubildr.mbr = "Ubuntu"

If you decide to edit the boot.ini, make sure you back it up, and edit it from the same place.

It should look something like this:

[boot loader] 
timeout=10 
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS 
[operating systems] 
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect 
C:\wubildr.mbr = "Ubuntu" 

For Windows 7, right click on Computer, Properties, Advanced system settings (on the left):

enter image description here

Then click on Startup & Recovery settings:

enter image description here

Make sure the Time to display list of operations systems is set to 10 or above. If that's not the problem, run CMD.EXE selecting to Run as an administrator, then enter bcdedit to make sure there is an entry for Ubuntu.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.