Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I recently switched to the Colemak layout after a fresh install of 11.10. Now, whenever I log in, the keyboard is set to QWERTY (USA), which is very confusing. How do I make it so that only Colemak is the only layout used?

share|improve this question
up vote 0 down vote accepted

I'm on OpenBSD now so my Ubuntu-specific knowledge might be a bit off, but you can do what I did (I'm also a Colemak convert) for Ubuntu.

For console, add

loadkeys colemak

(or it might be)

loadkeys linux_console/colemak.iso15.kmap

to /etc/init.d/local

Refer to the RcLocal Howto to set up rc.local for Ubuntu and the Colemak Linux/Unix page for additional console and Xorg configuration info.

You can set the Colemak Layout from GDM (at the bottom) and from System/Preferences/Keyboard when logged in

share|improve this answer
    
there's no way to switch the keyboard layout on the login screen any more. I'll have to look into the other suggestions tomorrow. thanks for the answer regardless. – geowa4 Nov 4 '11 at 2:07
    
oh no. i didn't know they changed that, too. might have to modify/actually make the xorg.conf to get colemak system-wide. – gregnotcraig Nov 4 '11 at 5:49
    
Option “XkbRules” “xorg” Option “XkbModel” “pc105″ Option “XkbLayout” “us” Option “XkbVariant” “colemak” – gregnotcraig Nov 4 '11 at 5:55
    
where can i put that? there's no xorg.conf any more either. :-P – geowa4 Nov 4 '11 at 12:15
    
you can either run X -configure or do it the "new way" by making an xorg.conf "snippet" and placing it in /usr/share/X11/xorg.conf.d – gregnotcraig Nov 4 '11 at 23:04

I had this problem before, my keyboard disposition was switching to qwerty every time I boot. Open a terminal and type the command:

ibus-setup

A window will appear, in the advanced section, select:

Use system keyboard disposition
share|improve this answer
    
@andrew-46: Could you please review my edits and also review the editing help to improve the readability of your own edits in the future... ;-) – Fabby Jan 3 at 2:27
1  
@Fabby: thanks for the steer :) – andrew.46 Jan 3 at 2:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.