Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've recently bought a Toshiba Satellite C655. It came with Windows 7 preinstalled. I've never had a notebook before, but as a desktop user, I was a Ubuntu user since 2 years, and I've never had a problem with drivers, wifi, etc.

When I tried to install the Ubuntu 10.04, and also the new and fresh 10.10, in my new laptop, I experienced some troubles with some of the componentes of my computer. For example, I was not able to activate my wi-fi card, although I know the kernel recognizes it correctly, because when doing "lspci" at the terminal, it was listed.

Anyhow, I'm not able to "activate" the wifi, or whatever it's necessary to do in order to be able to search for public networks available, and to connect with them.

The wifi-card the laptops brings is the (the lspci output):

03:00.0 Network Controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) [168c:002b] (rev 01).

It's anything in you can help me? Thanks a lot in advance!


Edit

Neither solution seems to work. In first place, i've tried installig what hhlp told me. After the installation, nothing seems to change: on right-clicking the wireless icon, it seems to recognize the card, because the option "Enable wifi" was ticked. But, once again, i was not able to "turn the wi-fi" on.

In second place, i didn't try installing the drives, because the card is already recongnized. The issue is that i cannot seem to turn it on!

One thing i've probably missed is that the Toshiba cames with a windows sofntware that allows you to enable / disable the wifi tools. So, it does not have an external "button" to turn it off. I don't know if that's the problem, but i have the feeling that the issue may be aroud there: in how to turn ON the wifi-signal (or to verify if it's on or off) in my ubuntu.

share|improve this question
    
That is the same wifi card I have in my laptop... works fine... –  TheX Oct 15 '10 at 14:49
    
Are you still having this issue or did you ever find anyway to solve it? If you feel that this question is no longer an issue and since there is not really any activity related to it you are free to delete it. If the question is still an issue for you then add a comment so further work can be done to solve it. Regards –  Bruno Pereira Nov 28 '11 at 0:57
add comment

3 Answers

you have a ath9k

ath9k is a completely FOSS wireless driver for all Atheros IEEE 802.11n PCI/PCI-Express and AHB WLAN based chipsets.

AR9002:

*      AR9220 (>= 2.6.27, an AR9280 card over PCI)
*      AR9280 (>= 2.6.27)
*      AR9281 (>= 2.6.27)
*      AR9285 (>= 2.6.29)
*      AR9287 (>= 2.6.32) 

have you tried install this :

linux-backports-modules-wireless-maverick-generic Install linux-backports-modules-wireless-maverick-generic

share|improve this answer
add comment

https://help.ubuntu.com/community/WifiDocs/Device/Atheros/AR9285

I use the Release Candidate 5 (nov 2010) in my time and it works.

No need to know about the wifi button it mention, or any wifi utility on windows.

It work I use Ubuntu 10.10 32 bit.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.