Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

the problem here is: when I'm using DHCP, everything works just fine. I'm changing /etc/network/interfaces to use static ip like:

iface eth0 inet static
address 192.168.0.200
netmask 255.255.255.0
network 192.168.0.0
broadcast 192.168.0.255
gateway 192.168.0.1

restarting networking service: sudo /etc/init.d/networking restart

after restart, /etc/resolv.conf contains valid router's ip, tracert shows exactly the same hops, I can access any device within my local network, but when I'm trying to open a page or connect to the host out of my local network I'm getting: 'host is not resolved'.

That would be really nice if somebody could point me to my mistake(s). What am I doing wrong?

share|improve this question
add comment

4 Answers

It sounds like your router does not resolve external host names (possibly a security measure?). Try another DNS server, like Google's Public DNS server:

# Contents of /etc/resolv.conf
nameserver 8.8.8.8
share|improve this answer
    
will try that, but I'm not really sure the problem is there because my Windows based server works perfect having DNS requests routed to the router directly. and my main concern was if router doesn't resolve external NS, how does tracert work and gives me the same hops and timeouts as if everything configured to use DHCP? I mean all that sounds and looks like a mystery to me... –  Alex D Nov 4 '11 at 4:09
add comment

Your setting look OK to me. I think there is a bug in an update. All my computers are on fixed IPs and have been working just fine for a long time. My desktop runs Ubuntu 11.04 Classic whilst all others run Xubuntu 11.04. Now suddenly they all don't work any more. No, it isn't the router or the cable modem - they've been replaced. If I change to DHCP on a computer is will grab the same IP and will work. On a fixed IP it will connect and I can ping the router but there is no Internet by IP or by name. So, you could have a bug and be chasing a problem that is not your making.

share|improve this answer
add comment
up vote 0 down vote accepted

Thanks everyone for your help and tips! problem is found and resolved. for some reasons interfaces file was corrupted. Restarting systems and recovering interfaces from previous edits with vim helped. When vim recovered this file, interfaces were edited again with the same settings. restart network interfaces and here'we go: system is online and uses static IP.

share|improve this answer
add comment

If what you posted was your entire /etc/network/interfaces, the problem was a missing "auto eth0" line. This line brings UP the interface automatically when you run /etc/init.d/networking restart.

Regards

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.