Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

First of all, thank you very much for providing this useful forum. Too bad for me, there is no support for the Acer Aspire S3 yet (just came out in October)

Short Description of the Problem: I cannot adjust the screen brightness. Neither Compiz nor the FN Key combination work. Also the fan keeps running on full power. As you can guess, both of these drain my battery.

The Setup: Acer Aspire S3, Intel i5 newest Generation, Intel HD3000 Grafic Accelerator (no driver maybe?)

Thanks in advance, Kakadu90

share|improve this question

11 Answers 11

Hi I've had the same computer since two days ago. To be able to set the brightness, I've modified the line:


to this:

GRUB_CMDLINE_LINUX="quiet splash acpi_osi=Linux acpi_backlight=vendor"

in the file /etc/default/grub, then:

sudo update-grub

Now I can set the brightness with the hotkeys, you can go so low that the screen is completely black... I just have a problem when the screen goes to sleep; I can't get it back. (I have to close the screen to put the computer in sleep and reopen it...)

Have you found a way to get the touchpad scrolling functional? And did you find the solution to set the fan speed?

Except for those little thinks it's a great thin, light and responsive laptop. I really hope those problems will be fixed soon.

share|improve this answer
Worked for me on Acer TravelMate 4750 with Ubuntu 11.10 – Indika K Apr 24 '12 at 16:56
Worked for me on Lenovo B Series.............. – webcoder May 22 '13 at 10:44
Worked for me on Acer (don't know which one) with Ubuntu 12.04 BUT I had to re-start for the change to take effect. – AJ Dhaliwal Jun 22 '13 at 9:29
It fixed the brightness issue for me. However, now when I use the Fn key to adjust the screen brightness, the slider bar does not appear on my screen to show where on the spectrum my current brightness level lies. Not a big deal, though. – Chris Morris Aug 3 '13 at 18:27
This also work for Acer TravelMate 8481. – Radu Rădeanu Aug 8 '13 at 4:20

the same applies for me, I posted it

Fan runs constantly on an Acer Aspire s3

So maybe we can share one thread. So far I found out that there is a tool

to modify/read the embedded controller (it actually applies to acer aspire one, but it works for me, the readout. However, the fan cant be stopped using the registers valid for the acer aspire one. So far I did not find which registers are responsible or if it is really possible to control the fan/display brightness in this way. But its a first try. Please report any progress here :)

share|improve this answer

I have been working all day on the Acer Aspire S3 linux compatibility problems. I tried to summarize your suggestions and my own experience on this page.

Please feel free to add and comment the information gathered.


share|improve this answer

I too had this brightness problem. But it was fixed with the code

GRUB_CMDLINE_LINUX="quiet splash pcie_aspm=force i915.i915_enable_rc6=1 acpi_osi=Linux acpi_backlight=vendor"

My laptop is Acer Aspire 4752Z (Ubuntu 11.10).

share|improve this answer

I solved the problem on my acer on this way, just let me know if works for you too, ubuntu 11.10 Edit your file /etc/default/grub and add this two lines in the end


GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pcie_aspm=force i915.i915_enable_rc6=1"

Then sudo update-grub

After that install the kernel 3.2 is the one over 35mb the last one.

After this restart your laptop, you can check that the temperature is going down eventually and the battery time going up, aswell you can setup the touchpad under settings/mouse, finally two fingers scrolling.

Just let me know if works :),

share|improve this answer
This one worked for me. I'm using Acer Aspire 4750G. Maybe it is not necessary to add the first line (pcie_aspm=force) on its own? It looks redundant coz the kernel params already has it. It works without me adding that one. – Marky Oct 2 '12 at 3:18

Thanks timex, I've tried what you said and here is my report.

With the kernel you gave the touchpad is well recognized, but because the buttons are on the sensitive area, you can't click and move the mouse, because of that I can't move or resize a window or even select anything with the mouse, I have to use the keyboard for this not really convenient... And the right click button don't work anymore...

What does your grub options does? I don't really understand them but I'm curious?

I also keept my solution for the brightness, because this changes nothing about it (and I still have my dark screen problem when sector plugged)

If any other idea...

And you have everything working well on your aspire s3 with an older version?

share|improve this answer

I have an older Acer Aspire and have a similar problem - no backlight. After a look around the internet, I found adding setpci -s 00:02.0 F4.B=00 before exit 0 in /etc/rc.local will cause the backlight to turn on when the computer is turned on. Unfortunately, whenever I close my PC, I have to Ctrl-Alt-F1 it and run sudo setpci -s 00:02.0 F4.B=00 to get the backlight to turn back on. If there is a way to get it to work other than that(and the GRUB) please tell me.

share|improve this answer

I tried timex' solution and it seems to work. The fan is running continuously, but at a slow speed. The machine is quite cool. In Windows 7 its also running all the time, so that should be alright. I used the 3.0 kernel shipped with Oneiric on a Mint Linux installation. (linux-image-3.0.0-12-generic).

I noticed problems with the wireless chip, after some time wireless connections just disconnected. This can be fixed compiling the the compat wireless drivers for the 3.0 kernel.

By the way: I installed Linux on the SSD which is recognized as /dev/sdb by the installer. I deactivated the deep sleep mode in BIOS, because it seems like Windows uses the SSD only for this feature. No problems so far, just a great performance boost.

share|improve this answer

Dear timex and Florian,

thank you very much for the hints, I changed the grub config to


GRUB_CMDLINE_LINUX="quiet splash pcie_aspm=force i915.i915_enable_rc6=1 acpi_osi=Linux acpi_backlight=vendor"

and installed a newer kernel

cat /proc/version Linux version 3.2.0-030200rc2-generic (root@gomeisa) (gcc version 4.4.3 (Ubuntu 4.4.3-4ubuntu5) ) #201111151435 SMP Tue Nov 15 19:43:49 UTC 2011

and at least the backlight is now better. The fan still runs constantly (maybe I should use the 64bit edition, not checked yet)

All the best

share|improve this answer

Adding the line GRUB_CMDLINE_LINUX="quiet splash acpi_osi=Linux acpi_backlight=vendor" worked for me on my Acer Aspire One D270-1596 running Ubuntu 12.04. I had also experienced a dull almost unreadable screen on login and was getting rid of it by logging out as a user and logging back in. I commented out (put # at the beginning of the Grub line)


and that got rid of that problem.

I was more than a bit uncertain about modifying the Grub file as I'm a complete newbie with Ubuntu, but it worked.

share|improve this answer

Adding pcie_aspm=force as a boot option worked for me.

GRUB_CMDLINE_LINUX="quiet splash pcie_aspm=force i915.i915_enable_rc6=1 acpi_osi=Linux acpi_backlight=vendor"
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.