Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to share my Ubuntu 11.10 internet connection via my wireless to another computer via ethernet. When I try to share them I get this endless "Connection Established"/"Disconnected" loop. I've tried updating everything, tried using Firestarter, tried everything I knew to. The card is supported for this because I was able to do it back in 11.04. Any help would be nice. :)

share|improve this question
I'm experiencing the same but yet can't find an answer. Hope you receive one. – Papiux Nov 7 '11 at 21:36
See this question:… – Quaternion Nov 10 '11 at 4:08

here it is recommended to set IPv6 to "Ignore" and sudo killall dnsmasq

worked for me

share|improve this answer
Not working for me. With the wired connections I have done the IPv6 stuff and dnsmasq and still if I so much as think about sharing with the wired cards it starts the endless loop. – Luis Alvarado Dec 12 '11 at 1:48
Worked for me. Thanks. – Vicky Chijwani Jan 22 '12 at 20:49
Worked for me too: with Ubuntu 11.10 and 10.04, but I had to unplugg the ethernet cable, then it worked. – math Mar 4 '12 at 11:38

ICS seems to work perfectly despite the messages.

Killing the nm-applet from the System Monitor got rid of the messages and ICS was still working OK.


Go to the IPv6 Settings tab for the ICS connection, set the method to Ignore and uncheck the Require IPv6.... box.

share|improve this answer
Solved - go to the IPv6 Settings tab for the ICS connection, set the method to ignore and uncheck the 'Require IPv6....' box. – Martin Hoare Feb 1 '12 at 11:32

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.