Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just upgraded from 11.04 to 11.10 and after restart it showed the login screen. After login, only the desktop background shows with ubuntu 11.10 text at the bottom-left corner. Did my GNOME stop working ? My mouse pointer moves though, so its not a system crash.

These are my h/w specs : Ubuntu 11.04 x86_64 • Intel Core 2 Quad Q6600 2.4GHz 8MB cache 1066MHz Intel MoBo DG33 8GB DDR2 RAM @ 800MHz • 1GB 8600 GT nVidia Graphics Card • Dell SP2309W • LG Flatron L222WS

share|improve this question
add comment

5 Answers 5

If you can, log in to Ubuntu (Unity) 2D, and run unity --reset, then try to login the regular session again. This should fix the problem.

share|improve this answer
    
I logged into 2D and did unity --reset. All the desktop items and left hand menu bar vanished. I logged as normal ubuntu and desktop was still blank. But, if I login to tty (CTRL+SHIFT+1) and logout, my desktop items showup but the menu bar is missing. Also, if I open a textfile from the desktop, gedit pops up with the application's menu bar. –  anjanesh Nov 4 '11 at 2:20
    
@anjanesh are you able to log into Unity 2D? It sounds to me like Unity is crashing. If you can log in to the recovery console (from the log in screen), run unity and post the output it gives in your question. You might need to run gnome-terminal from the recovery console in order to capture the output. –  RolandiXor Nov 4 '11 at 3:23
    
I am able to log into Unity 2D. Im using it right now. –  anjanesh Nov 4 '11 at 4:19
    
Unable to copy the entire output of unity. The last lines are compiz (unity) - Warn : unsupported internal format. Segmentation Fault. –  anjanesh Nov 4 '11 at 4:35
    
<i>are you able to log into Unity 2D?</i> It shows as Ubuntu 2D and not Unity 2D. I hope its the same thing. –  anjanesh Nov 4 '11 at 4:45
show 2 more comments

I think my issue was related to Compiz settings, as I used to fine tune Compiz settings using CCSM in the past, and Unity being a Compiz plugin. In my case, renaming .config fixed the issue.

  1. Log out, press Ctr+Alt+F1 and log in to the command prompt
  2. Remove .compiz* directories in your home directory with "rm -fr .compiz*" command
  3. Rename .config directory with command "mv .config config_old"
  4. Log out using "exit" command
  5. Press Alt+F7 to return to GUI login screen
  6. Log in as normal
  7. Your desktop should now be back with default settings
  8. Copy over application settings files from config_old onto .config directory. Do not override any files.
  9. Re-arrange Unity panel items and configure keyboard if required using appropriate menus.

Hope this helps.

share|improve this answer
add comment

I found out that one privative driver for NVIDIA wasn't active. You must activate it to display icons well (on any desktop) and to run unity desktop without other severe troubles.

Actually, the driver replaces the usual driver i had. But it's named differently. I don't know in english, but it should be "acelerated graphics" or something like that.

share|improve this answer
add comment

I got this working using sudo apt-get install gnome-shell

share|improve this answer
1  
Did this fix Unity? –  RolandiXor Nov 5 '11 at 15:46
    
Ubuntu 2D was not broken in the first place. But my dual monitor settings was messed up (no Xinerama) and some other small GUI issues. –  anjanesh Nov 6 '11 at 3:14
add comment

Try resetting X:

sudo rm /etc/X11/xorg.conf
share|improve this answer
    
I renamed it in recovery console. Still no desktop. –  anjanesh Nov 3 '11 at 16:46
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.