Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

One of my user accounts logs in without system sounds in Ubuntu 11.10.

All other sounds works well, I can listen music, see movies, etc without a problem.

System sounds like errors, login, shut down, etc don't play.

Thanks for any help.

share|improve this question

2 Answers 2

Enable system sounds in System -> Preferences -> Sound. Maybe the output volume for system sound is set to zero or a low level.

Then check, whether there is a "startup application" called "GNOME Login sound" and that it is enabled. If it does not exist, create a new one with the following command:

/usr/bin/canberra-gtk-play --id="desktop-login" --description="GNOME Login"
share|improve this answer
    
Thanks for the quick reply but the sound volume for system sounds its ok. I can ear the alert sounds displayed below the sound bar in System -> Preferences -> Sound –  Maleficium Nov 3 '11 at 14:26
    
Okay then this is another issue, I edited my answer... –  Michael K Nov 3 '11 at 14:33
    
GNOME Login sound was in "startup application" and enabled. I disabled it and deleted it. After that the terminal gave me the follwing error: (canberra-gtk-play:6294): Gtk-WARNING **: Incapaz de localizar motor de temas na module_path: "pixmap", Failed to play sound: File or data not found Translation:Unable to find theme engine in path module –  Maleficium Nov 3 '11 at 14:39

Thanks for the help Michael. Your solution didn't solved the problem but gave me some ideas to search in another direction. The command in terminal gave me some errors and after a couple hours of searching here's the solution taked from another place:

  1. Open a terminal then type dconf-editor

  2. Navigate to org.gnome.desktop.sound in dconf-editor. The value for the key named "theme-name" should be "ubuntu" and not "freedesktop"

That error happens when the default sound settings its changed in Sound Preferences:

  1. When changing alert sound to "Default," the value of "theme-name" in dconf should revert to "ubuntu", not "freedesktop".

  2. When choosing an alert sound other than "Default", users will not reasonably expect that many of their other system sounds will disappear. Only the alert sound itself should change.

Solution taken from other site by the member Jay S

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.