Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I want to install Skype, but I can't locate it in Software Center or by using Synaptic Package Manager. Can anyone help me?

share|improve this question

11 Answers 11

Please note that Skype won't work if you have installed Ubuntu with Wubi. You must have ubuntu installed by itself from a CD in order for Skype to work.

share|improve this answer

11.10 & above Command Line

To enable the partner repository from the command line, edit /etc/apt/sources.list:
sudoedit /etc/apt/sources.list and remove the # from the beginning of these two lines:

12.04

deb http://archive.canonical.com/ubuntu precise partner  
deb-src http://archive.canonical.com/ubuntu precise partner

Then update your apt cache and install it:

sudo apt-get update
sudo apt-get install skype:i386 libasound2-plugins:i386
share|improve this answer
    
How about 12.10? –  Dan Dascalescu Dec 29 '12 at 16:09
    
@DanDascalescu, it is the same thing, except for the name precise which has to match your current version. You can see that in the other deb / deb-src entries in your directory. –  Alexis Wilke Apr 4 at 22:06

For Ubuntu 12.04 and above

Command line way:

sudo add-apt-repository "deb http://archive.canonical.com/ $(lsb_release -sc) partner"
sudo apt-get update 
sudo apt-get install skype

HELP

share|improve this answer
    
Error askubuntu.com/questions/285642/… Apr 29 2013 –  Qasim Apr 29 '13 at 8:58

As I always do:

sudo apt-get install ia32-libs -y

And then download the multiarch deb package of skype and finally:

sudo dpkg -i skypeDownloadPath.deb
share|improve this answer

For 12.04 and above

There appears to be a problem where skype does not show up in Software Center after following the previous instructions for 11.04 etc.

You'll still need to add the partners repository by following one of the other instructions for the GUI, or use the terminal to edit /etc/apt/sources.list so that the line

deb http://archive.canonical.com/ubuntu precise partner

has not commented (hashed) out.

You then need to update the repository information:

sudo apt-get upgrade

and can then install Skype from command line:

sudo apt-get install skype
share|improve this answer

10.04

To enable the partner repository that has Skype: Go to System -> Administration -> Software sources -> Other software, and enable the partner repository (on lucid 10.04, it's http://archive.canonical.com/ubuntu lucid)

Click close and let the program fetch updates for the repositories.

Then, using either Ubuntu software centre, synaptic package manager or apt-get, install the skype package.

share|improve this answer

For 11.10 and above

Starting in Ubuntu 11.10 multi-arch is used for applications that formerly used ia32-libs. Here is the official work around for Skype on AMD64 (I represent the release team):

Skype is a 32 bit binary and under Ubuntu 11.10 you must install the 32 bit version of Skype for both Ubuntu 11.10 i386 and amd64 versions.

You can get this from the Ubuntu Partner Repository.

To get it from the partner repository first enable it in your software sources, and then get it from the Software Center:

Click the ubuntu button, then search for "Software Sources", click on it, and go to the "Other Software Tab":

enter image description here

When you click close run the software center, and search for Skype.

enter image description here


If skype still does not appear in software-center, then close the application.

In a terminal type:

sudo apt-get update
sudo apt-get --reinstall install software-center

This will force the package management to be updated, followed by the software-catalog for software-center.

share|improve this answer
    
Added the partners repo, reinstalled the software-center, but Sykpe still doesn't show in search results. Ubuntu 12.10 64-bit. –  Dan Dascalescu Dec 29 '12 at 16:08
2  
Confirmed problem that Skype does not show up in Software center after doing all of this for 12.04, however the command "sudo apt-get install skype" did work for 12.04. Possible bug in Software Center? –  fabricator4 Jan 7 '13 at 19:09
1  
how about downloading it from the skype site and do a simple sudo dpkg -i skype.deb? –  Dr_Bunsen Jan 7 '13 at 19:29
    
@Dr_Bunsen - it won't work. skype will get installed but it misses some dependencies and once you start it a weird message on Problems with Audio Capture gets shown. –  Matteo Mar 5 '13 at 18:19
    
try apt-get install -f, should fix the depenceies (I can't spell that) issue. –  Dr_Bunsen Apr 11 '13 at 18:08

Installing packages manually is not recommended. But I have been installing Skype package manually for a quite some time through the Ubuntu Package manager without any problem. Just make sure you check any warning shown by during the installation.

Go to: http://www.skype.com/intl/en/get-skype/on-your-computer/linux/

Download the 64bit Ubuntu package. Once the download is finished, double click the package to start the installation through the Ubuntu Package manager. It will download any dependency and instal

share|improve this answer
    
Oh dear. This ubuntu ask makes me ask questions before having thought about the problem ;) Thank you! –  Wauzl Apr 2 '12 at 19:33

If you upgrade to Ubuntu 11.10 on a 64-bit platform and try to run skype then you will likely get this error:

skype: error while loading shared libraries: libXss.so.1: cannot open shared object file: No such file or directory

This is because libxss1 and a few other libraries have been removed from ia32-libs package.

You will need to enable multiarch and install the extra 32 bit libraries by hand:

echo foreign-architecture i386 | sudo tee /etc/dpkg/dpkg.cfg.d/multiarch
sudo aptitude update
sudo aptitude install libxss1:i386 libqtcore4:i386 libqt4-dbus:i386

This is all that is required to get the statically compiled version of Skype to work.

If you are running the dynamically compiled version or one that comes from mediabuntu or other source, you will need to pull in an extra package. sudo aptitude install libqtgui4:i386

However, in my experience this pulls in too many unnecessary packages and some of them may be broken.

Update: I’ve done a fresh install of Oneiric and determined the following list of packages that need to be install to get skype working. In the mean time, please bug/pester Skype for real 64bit binaries.

sudo aptitude install libxss1:i386 libqtcore4:i386 libqt4-dbus:i386 libasound2:i386 libxv1:i386 libsm6:i386 libxi6:i386 libXrender1:i386 libxrandr2:i386 libfreetype6:i386 libfontconfig1:i386

http://www.mindwerks.net/2011/09/skype-on-ubuntu-11-10-oneiric-ocelot/

share|improve this answer

For 10.10

To install Skype, you need to enable the canonical partner repositories.

Add this repository: deb http://archive.canonical.com/ubuntu maverick partner

This may already be available but not installed. If so, just tick the box next to the partners repository:

enable partners

When you close the software sources window it should refresh your packages and Skype should be available to install from the Software Centre.

share|improve this answer
1  
What is Canonical partners? why we need to enable them before I install skype? –  Kit Ho Mar 29 '12 at 15:19
    
@KitHo, you should ask this as a question form instead as a comment. –  Gediminas Jeremiah Gudelis Aug 28 '13 at 15:42

You have to use Canonical partner repository. To enable it, use these commands:

echo "deb http://archive.canonical.com/ubuntu/ $(lsb_release -cs)/partner Packages" | sudo tee -a /etc/apt/sources.list
sudo apt-get update
sudo apt-get install skype
share|improve this answer
2  
Replace lucid in your code with $(lsb_release -cs), it returns the codename of the currently installed version :) –  Lekensteyn Apr 11 '11 at 14:49
    
Hmm, really, thanks for it. –  B. Roland Apr 11 '11 at 14:51
1  
I've prefixed your line with deb, otherwise the file was broken. The <pre> tags have been replaced with four spaces for proper syntax highlighting. –  Lekensteyn Apr 11 '11 at 15:01
    
oh yes, you are right... I was just careless... now it will work well :) –  B. Roland Apr 11 '11 at 15:06

protected by fossfreedom Dec 27 '13 at 8:25

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?