Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have 1 usb disk and 1 esata disk plugged in my pc. When I log in gnome-shell the usb one is mounted automatically. Is there any way to mount the esata disk too, without modifying fstab?

share|improve this question
up vote 2 down vote accepted

No. The system assumes that sata disks are internal, and therefore, does not auto mount them if they don't have an fstab entry. Is there a reason you don't want to add an fstab entry?

share|improve this answer

A better and easier way to do that in Gnome3.4 (with Gnome-Shell) is using the GNOME Disk Utility. I had to go for that because Ubuntu did not like de AriOS package (warning said it's bad software) and the pySDM is not that clear about the partitions. I always get confused trying to remember wich one is /sda1 or /sda3 or what so ever. It should show the labels! The Gnome Disk Utility is really great. You can find it at Activities > Aplications > System Tools > Disks (sorry, not sure 'cos I'm using the brazilian-portuguese translation).


For my brazilian fellows now: A melhor opção é usar o aplicativo Discos do Gnome (gnome-shell). Vá em Atividades > Aplicativos > Ferramentas de Sistema > Discos. Clique na partição e no ícone de configurações abaixo dela. Lá, desative a montagem automática e escolha a opção LABEL no último menu, pois essa opção monta a partição com o nome (label) que você deu para ela no Windows.

share|improve this answer

There is a system service (man udisks(7)) that handle a mounting jobs in cooperation with udev. You can write udev rule to mark your esata disk as external and partitions on disk as automountable. Something like that:

KERNEL=="sd[b-z][1-9]", SUBSYSTEM=="block", SUBSYSTEMS!="usb", ENV{UDISKS_AUTOMOUNT_HINT}="always"

To play around with this, try udisks console tool with --mount, --unmount, & --monitor options.

It works for me on Ubuntu 12.04.1 GNOME3 Fallback session

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.