Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

could you help with my boot time. I´ve tried some solutions with no results, including:

  • nomodeset as grub boot option
  • kernel upgrade to 2.6.39

Here´s the image of bootchart

And here´s the dmesg & lsmod | grep tpm -at the end- output

On Ubuntu 11.04 , Kernel 2.6.38-12-generic, Graphic card: Nvidia GeForce 8400M GS

Thanks in advance

share|improve this question
if the answer does not work for you - please add the results of lsmod | grep tpm to your question. –  fossfreedom Nov 2 '11 at 22:53

1 Answer 1

Your system is trying to load the driver for Trusted Platform Module chips but its not being able to do so. I am not sure about your current hardware, because there is no information on your question, but you can try to blacklist that module (its not loading anyways).

Edit /etc/modprobe.d/blacklist.conf (sudo nano /etc/modprobe.d/blacklist.conf or similar using your fav text editor) and add the line blacklist tpm_tis.


share|improve this answer
Hi @brunopereira81 I´ve tried add the line to /etc/modprobe.d/blacklist.conf with no results, stills hanging up the same time. Thanks –  Ari Nov 3 '11 at 0:21
Please follow foosfreedom advice, paste it to the question. –  Bruno Pereira Nov 3 '11 at 6:55
I´ve add the lsmod | grep tpm to it´s at the end of the text, is just that i can´t add more than two url. Thanks –  Ari Nov 4 '11 at 5:35

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.