Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

It seems something else than gnome-power-manager manages the backlight dim timeout on Thinkpads, maybe thinkpad-acpi.

How do you alter the timeout from 5 seconds? (which is very annoying)

share|improve this question
    
The display driver might take a role in here. What display driver are you using? –  Thomas Nov 2 '11 at 20:56
    
The official nvidia one. I remember having much trouble about the display driver in the beginning. –  jonallard Nov 2 '11 at 22:38
    
Can't say for nvidia. The Radeon Catalyst Control Panel has an option "Vari-Bright" that, when enabled, produces the behavior you described. –  Thomas Nov 3 '11 at 17:01
add comment

1 Answer 1

I had this issue on a Thinkpad x220. The following message showed up in /var/log/dmesg:

[ 10.262915] thinkpad_acpi: Standard ACPI backlight interface available, not loading native one

You can tell linux to let a vendor specific driver (thinkpad_acpi) handle the backlight by passing the acpi_backlight=vendor option to the kernel.

To do this:

  1. Edit /etc/default/grub
  2. Add acpi_backlight=vendor to the list of options in GRUB_CMDLINE_LINUX_DEFAULT
  3. Run sudo update-grub

The backlight is now managed by thinkpad_acpi and does not dim after 5 secs.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.