Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an Acer Aspire One with a dual core AMD 1GHZ processor and 2GB of ram.

I have Ubuntu 11.10 installed (full install, not wubi). I had this problem when I was using wubi, and I thought a full install would fix it but most of the time when I boot up ubuntu, after about 15 seconds on the desktop, it freezes, neither the mouse does not move nor clicking does not work, key combinations don't work. I am a relative n00b to linux but is there any way to fix this?

share|improve this question

closed as off topic by Marco Ceppi Feb 3 '12 at 1:22

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Welcome to Ask Ubuntu! It sounds to me like you are experiencing some sort of X freeze. Can you take a look at this Ubuntu Wiki article on diagnosing X freezes if you have a spare computer you can use to help with debugging and file a bug report? Thanks! –  Christopher Kyle Horton Dec 5 '11 at 13:59
    
I am also experiencing the same issue. Any luck resolving it? –  Celil Dec 15 '11 at 21:07
    
This question should instead be filed as a bug report, and as such is off-topic, thanks! Instructions here. –  jrg Feb 3 '12 at 1:15

3 Answers 3

Try this: connect the Internet with wired cable first, then start your computer. If every thing is good, then the most probably problem is the Ethernet card and the wireless card share the same ID. If this is the case, you simply make PCI Lan disabled in BIOS.

share|improve this answer
    
Thanks, I don't have an issue with the internet, the entire system freezes on me. I cant do anything. –  Steve Nov 3 '11 at 23:56
    
But, there is an issue with the Aspire One freezing when it tries to connect wirelessly to the Internet. This may be the case as the machine boots and attempts to make a wireless connection automatically. The advice to try a wired connection is sound as this will either confirm or eliminate this issue as a cause. Should it be the problem, one fix is to disable the Ethernet controller and just use the wireless card. See: linuxnorth.wordpress.com/2011/10/23/wireless-less for more information and detailed instructions on how to disable the Ethernet controller. –  CentaurusA Dec 5 '11 at 15:41

It sounds like you might be experiencing a bug where Acer Aspire One's tend to freeze while trying to connect to a wireless network. A simple way to test it out (and to fix it if this is the problem) is to set "Network Boot" as the top priority in your BIOS's boot order. You can do this by pressing F2 to enter your BIOS settings. Navigate to the "Boot" setting and move "Network Boot" to a higher position than your hard drive (Preferably the top).

If the freezing still happens, you can undo this by moving network boot back to a lower priority.

Source: http://bernaerts.dyndns.org/linux/202-ubuntu-acer-ao722

share|improve this answer

I was able to trace a similar problem to the rtkit-daemon, or perhaps one of the processes that use it (the last entry in the syslog always had rtkit in it).

After reading the man page for the rtkit-daemon, I tried adding the line

RLIMIT_RTTIME=1

to the file

/usr/share/dbus_1/system_services/org.freedesktop.Realtime

Worked, to my great surprise. The 1 above was just an arbitrary guess.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.