Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Lenovo Ideapad y510 with 5.1 sound and worked perfectly on Windows.

I read a guide to get 5.1 sound on Ubuntu which proposes to do the following.

Edit /etc/pulse/daemon.conf and change the default-sample-channels from 2 to 6.

Then edit /etc/modprobe.d/alsa-base and add the line

options snd-hda-intel model=3stack-6ch-dig

and restart the system.

After the first reboot the sound works perfectly, but when I power off or restart the machine the sound does not work.

How can I make those changes permanent?

share|improve this question

2 Answers 2

I was too having trouble using 5.1 channels; this youtube video solved it for me: How to setup ubuntu to use all surround sound speakers ...

share|improve this answer
1  
Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. The shown solution seems to soundchip or soundcard specific. If one has this option, one might check it, but generally 5.1 sound should work. –  LiveWireBT Dec 10 '13 at 3:00

Try setting the sound profile the normal way first. Click the little speaker icon at the top right of the desktop and choose 'Sound Settings...'. Click the Hardware tab in the window that comes up, and click on your audio device to configure. Then click on 'Profile:' and choose the profile you want, 5.1 in your case. You may have more than one 5.1 option, depending on your setup and motherboard outputs. Test that it works and then restart. The settings you changed should stick.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.