Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Sharing files between my Guest Kubuntu OS and Host Windows has become a real headache.

So, far I have done the steps below:

GUEST LINUX OS

  • VM -> Settings -> Options -> Shared Folders. And added my folder.
  • Installed properly my VMware tools (I can drag and drop files so I am confident that it is installed)

HOST WINDOWS OS

  • Shared the folder with everyone (to assure that there is no permit limitations with my files)

If I type vmware-hgsclient in my guest OS, the folder I am sharing does appear. But when I check the /mnt/hgfs folder, it is empty.

I have gone through the VMware manual, and I am sure that I have followed their requirements.

I am really out of ideas. Any one has a suggestion?

share|improve this question

3 Answers 3

I had this exact problem. It turned out IT had installed some old version of VMWare tools with non-functioning vmhgfs kernel module.

My solution was to run the configuration with the clobber-kernel-modules setting to overwrite the existing vmhgfs module.

 sudo vmware-config-tools.pl -d --clobber-kernel-modules=vmhgfs

The -d selects all the defaults for you (remove it if you don't want the defaults).

share|improve this answer
    
bingo, I had the same issue, and running the command above solved it. Thanks a bunch. –  Waqas Sep 20 '13 at 16:14
    
Just want to mention that this worked for me with OSX as host, vmware Fusion running CentOS 6.4 –  Amida Nov 29 '13 at 11:58
1  
Perfect! Worked for me with OSX as host and VM runnig Ubuntu 14.04 –  pjvds May 2 at 12:18

mount -t vmhgfs .host:/share /mnt/hgfs/ where host is the host you are connecting to share is the share name and /mnt/hgfs is the mount point for the share in your system.

vmware-hgsclient will show you the available mounts, you still need to mount them with vmware-hgfsmounter or using the mount command above described.

If that does not work check if the module vmhgfs is loaded lsmod | grep "vm."

share|improve this answer
    
It gave me this answer. Host in share name must be ".host". Error: share name is invalid, aborting mount. vmhgfs is not loaded, how can I load it? Thanks. –  Peretz Nov 2 '11 at 16:53
    
mkdir /mnt/hgfs/ –  syslogic Feb 27 '13 at 5:21

For me, it turned out that vmware-hgfsmounter was not installed (ubuntu 12.10). After installing that module, I was able to mount my share as descibed above

share|improve this answer
    
I have it installed in /usr/lib/vmware-tools/sbin64, but it still doesn't work for me. –  Igor G. Oct 31 at 14:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.