Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

A bit before upgrading from 10.04 to 11.10, my Ubuntu desktop stopped allowing me to access my Windows share directories. I figured I'd upgrade to 11.10 and the problem would get fixed but no.

Whenever I click on a Windows network domain using Nautilus, the message:

" Unable to mount location - Failed to retrieve share list from server " pops up.

Where do I start troubleshooting this problem? I am getting desperate now :(

  • I tried sudo mount -t cifs //SomeMachine/SomeShare some_directory and I get mount error(115): Operation now in progress
  • Strangely enough, I got a popup stating: Could not display network:/// Error: Dbus error org.freedesktop.DBus.Error.NoReply: Did not receive a reply ...
share|improve this question
    
Is this a network you control? Can you look on the server logs to check for errors (Windows Event Logs, etc). Can you check in your own logs (/var/log/syslog) and report any anomalies? –  dpb Nov 2 '11 at 15:08
    
Nothing pops up in /var/log/syslog related to the matter :( –  jldupont Nov 2 '11 at 15:23
    
Have a look here had an user with a similar problem. –  Bruno Pereira Nov 2 '11 at 15:27
    
Follow the steps we used there an edit your q with the results. –  Bruno Pereira Nov 2 '11 at 15:28
    
@brunopereira81 I've checked out your link to no avail. The problem is on my ubuntu machine side. It used to work just fine up until some update on 10.04 :( –  jldupont Nov 2 '11 at 15:36
show 3 more comments

5 Answers 5

This is the true answer of your question. I also had the same problem.

Run terminal and enter this command

gksudo gedit /etc/hosts

and add computer ip address and name in hosts file. Save and exit.

Sample ip and name:

192.168.120.65    blablaPcName

Thats all.

share|improve this answer
    
And what do you suggest for when the other computer doesn't have a static IP? Not everyone has control over the router. –  Fambida Jan 1 at 20:12
add comment

I found this advice from Gord Nickerson worked for me: The error message is 'failed to retrieve share list from server' so it cannot browse a Windows 7 pc or a Ubuntu 10 pc or a mac desktop pc.

smbtree lists all the shares from machines on the network

so off to /etc/samba and we sudo pico smb.conf

The name resolve order uses hosts files first and broadcasts last and it is commented out! Maybe we change that to:

name resolve order = bcast host

and then restart the servers with service smbd restart and service nmbd restart

Works! This is an awful mistake to make in an upgrade. Upgrade should not break what is working, particularly something as important as networking. Good thing i recall the manual work you had to do to get samba working back in redhat 5 and 6.

share|improve this answer
    
do you know if this should work on 12.10? –  Aquarius Power Nov 15 '13 at 12:27
    
This worked for me on 12.04 –  Jonathan Mar 11 at 15:42
add comment

It's possible this is a general error connecting to the system:

In the above thread case, there was a mismatch between name and IP address, and nmblookup helped determine the problem. Also, this page seems to have some good troubleshooting tips

That I'm copying out:

  • Put smbclient into debugging mode, output should show up in dmesg (-d|--debuglevel=level)
  • smbclient -L //<IP of Samba Server> -U <server user>
  • nmblookup {name}
  • Can you mount from other systems?

Edit up your question if you do more troubleshooting.

share|improve this answer
add comment

I've had very good results in mixed network environments (Windows/Ubuntu) with this method:

  1. Press Alt+F2 and type: gksu gedit /etc/nsswitch.conf

  2. Look for this line:

    hosts:  files mdns4_minimal [NOTFOUND=return] dns mdns4
    
  3. Add wins so it looks like this:

    hosts:  files mdns4_minimal [NOTFOUND=return] wins dns mdns4
    
  4. Install the "winbind" package: sudo apt-get install winbind

    (Or via Software Center or Synaptic.)

  5. Reboot or restart your network.

share|improve this answer
add comment

Just add "allow out" to the firewall:

  • Port 137/UDP - used by nmbd
  • Port 138/UDP - used by nmbd
  • Port 139/TCP - used by smbd
  • Port 445/TCP - used by smbd

And it will work, and if you do not know how to, just install "gufw", and use the "+" and then the "simple tab".

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.