Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Currently I'm running Ubuntu 11.10 64 Bit on my laptop and I want to install some Windows programs with Wine (Dreamweaver CS5/Starcraft II etc) but these programs require the 32Bit version of Wine to work even being in a 64Bit environment... I'm a Fedora user most of the time and in that distro installing 32Bit versions of apps inside of a 64Bit system is never a problem, but didn't find a way to do that on Ubuntu.

share|improve this question

6 Answers 6

up vote 11 down vote accepted

Things have changed since my original answer. The version of Wine you install on a 64bit computer these days is capable of running in both a 64bit and 32bit capacity. This is decided by the prefix (the local bundle of files, traditionally at ~/.wine/).

Once you've set up a 32bit prefix, everything will run in 32bit mode in that prefix. Conversely, if you don't do anything and run anything with wine (or its ancillary commands), you'll create a Wine64 environment... And these are buggy as all hell still.

If you're upgrading an old prefix (and I think this is why I hadn't appreciated this before today), it will carry on using the same architecture. My ~2010 prefix just kept working.

If you're starting a new prefix (ie on a new install of Ubuntu), you'll need to do a few special things:

# Move the old prefix (if one exists)
# You could rm -rf it if you don't want it.
mv ~/.wine/ ~/oldwine/

# Create prefix with right arch, per
# http://wiki.winehq.org/FAQ#32_bit_wineprefix
WINEARCH=win32 winecfg

And that's it. Unless you're specifying another prefix that doesn't exist yet, you shouldn't need to set WINEARCH again.

And ultimately, as Wine64 matures, this should be something that's less and less relevant. Wine64 should be able to run 32bit applications.

share|improve this answer
    
Fixed the problem: Installed Wine 1.2 via PlayOnLinux and then ran the apps that won't run via the terminal, looked at the output. In the case of dreamweaver, it was matter of installing "vcrun2008" using winetricks. It runs fine now, thanks! –  Manuel Escudero Nov 4 '11 at 21:32

Step 1: Install wine 1.4. This version of wine supports win32 and win64.

Step 2: Open a terminal.

Step 3: export WINEPREFIX=prefix32

Step 4: export WINEARCH=win32

Step 5: winecfg

Step 6: Enjoy, the new prefix is set for 32-bit execution.

This is the proper way to do this. Installing cross-arch packages is a dirty fix that's likely to cause you trouble.

share|improve this answer
    
Steps 3 and 4 solve many wine problems and performance issues with several games. This is a must when installing Wine on a 64 bit OS. –  Luis May 31 '13 at 0:50

On Ubuntu Oneiric, the 32-bit binaries and libraries of Wine are installed by default. No special action is necessary other than installing wine.

Confirmed with:

$ file `which wine`
/usr/bin/wine: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.15, stripped
share|improve this answer

The best ways to do this:

  1. (Permanently) Edit /etc/environment:

    • sudo nano /etc/environment

    • Add the following line:

      WINEARCH=win32

    Note: by the above solution, wine & wibom use always the 32 bit version of wine.

  2. (Temporary) Open a terminal(Ctrl-Alt-t) and type:

    • `env WINEARCH=win32 wine or
    • `env WINEARCH=win32 winecfg for 1st .wine 32 bit bottle
share|improve this answer

. Was having the same problem. I just upgraded to Ubuntu 14.04 64-bit and was trying to get Office 2007 to work. It won't run in a 64-bit wine configuration. After a lot of searching, this is what I came across:

  • The folder in which all your wine software are installed is known as your WINEPREFIX. By default this folder resides in your home (~) directory by the name '.wine'. There can be more than one WINEPREFIX.
  • There also exists an environment variable known as WINEARCH which represents the mode of your current wine settings, i.e. 64-bit or 32-bit.
  • THIS IS IMPORTANT. At the time of the creation of a WINEPREFIX the value of WINEARCH decides the mode in which wine will function when running applications from that WINEPREFIX.

By default the WINEARCH variable is set to the value 'win64' (stands for 64-bit) on a 64-bit Ubuntu installation therefore the automatically created WINEPREFIX has a 64-bit operation mode. In order to change this mode we need to 1) delete the current WINEPREFIX. 2) set WINEARCH to 'win32' 3)Create a new WINEPREFIX. The Steps: NOTE: These steps are to be done after installing wine. You can easily do that using the Ubuntu Software Center. search for Wine 1.6 and click install.

  1) Open up the terminal by pressing Ctrl + Alt + T. And type the following commands:
   cd ~
   rm -rf .wine
   rm -f .config/menus/applications-merged/wine*
   rm -rf .local/share/applications/wine
   rm -f .local/share/desktop-directories/wine*
   rm -f .local/share/icons/????_*.xpm 

   2) Now to set your enviroment variable and also to create your new 32-bit WINEPREFIX go ahead and type:
   WINEARCH=win32 WINEPREFIX=~/.wine winecfg

That's about it I guess! This worked for me! now all you need to do is to install your 32-bit applications.

share|improve this answer

You can install 32bit Packages by using:

sudo dpkg --force-architecture -i whatever.deb

You need to download the wine-package for i686.

But you should be carefull to have the correct libraries installed as well.

sudo apt-get install ia32-libs

is the minimum you should do.

However, I never had a problem with a program not running in wine because of 64-bit ubuntu and much Windows-Software is 32bit.

share|improve this answer
    
This is unrelated to the question, installing wine on Ubuntu 11.10 Oneiric automatically pulls in the 32-bit packages, no need for forcing architectures. –  Lekensteyn Nov 2 '11 at 9:34
    
Well if you know the answer, please post it as answer, then I can and will delete my answer which will also remove this comment. –  Michael K Nov 2 '11 at 9:42

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.