Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a problem with my ubuntu 10.04.3 server. After changing user home directory(usermod -m -d /home/username username) my system began work very strange. When try to use "ls -la" command, bash said me that "no such command found".Same output for "cat" command.I tried to restart machine, but after restarting the following messages appeared on screen(something like this): failed to spawn hostname main process failed to spawn plymouth main process failed to spawn hwlock main process failed to spawn mountall main process

Does everybody knows what happened? I will very appreciate for your help.

share|improve this question

1 Answer 1

Did you copy the contents from the old home directory to the new one? At least you may need to copy the old .bashrc.

Try the following:

cp /home/old/.bashrc /home/new/.bashrc

Better would be to copy even more configuration files to the new home directory.

Background information: bashrc sets up the PATH environment variable, which points to the directories with executables (e.g. cat, ls) - without this file bash, the PATH variable is not set up correctly and bash does not know where to find cat and ls and others, which results in this issue.

You can check the path variable by doing:

echo $PATH

this should output sth like this:

/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.