Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've been having garbled screen problems on a Gateway LT3103u on Ubuntu for a while. I just did a fresh install of Ubuntu 11.10 and continue to have issues. I installed xubuntu-desktop in case the issues had to do with the sophisticated GNOME graphics. The problem is less bad, but it's still there. After a few minutes of using XFCE, the screen gets garbled. I assume this has something to do with the graphics card, but I don't know how to go about troubleshooting something like this. Where should I start? garbled screen

Update: Here is the description of the VGA card from lspci -vvv:

01:05.0 VGA compatible controller: ATI Technologies Inc RS690M [Radeon X1200 Series] (prog-if 00 [VGA controller])
Subsystem: Acer Incorporated [ALI] Device 028c
Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Latency: 64, Cache Line Size: 32 bytes
Interrupt: pin A routed to IRQ 18
Region 0: Memory at d0000000 (64-bit, prefetchable) [size=256M]
Region 2: Memory at f0100000 (64-bit, non-prefetchable) [size=64K]
Region 4: I/O ports at 9000 [size=256]
Region 5: Memory at f0000000 (32-bit, non-prefetchable) [size=1M]
Expansion ROM at <unassigned> [disabled]
Capabilities: [50] Power Management version 2
Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
Capabilities: [80] MSI: Enable- Count=1/1 Maskable- 64bit+
Address: 0000000000000000  Data: 0000
Kernel driver in use: radeon
Kernel modules: radeon

Update: Setting GRUB_CMDLINE_LINUX="nomodeset" in /etc/default/grub seems to have fixed it in both Ubuntu and xubuntu-desktop. I will test it for a day or so to see if the problems recur and then post more detail with some links to an explanation.

share|improve this question

2 Answers 2

up vote 2 down vote accepted

It turns out this post is the answer I was looking for. The trouble is something called kernel mode-setting (KMS), which according to the Ubuntu wiki

shifts responsibility for selecting and setting up the graphics mode from X.org to the kernel. When X.org is started, it then detects and uses the mode without any further mode changes.

However, Radeon graphics cards are unevenly supported by the kernel, and KMS is turned on automatically in newer versions of Ubuntu, despite it not working with older cards. This is probably the reason why upgrading Ubuntu caused these problems.

To remove KMS in GRUB 2, add nomodeset to GRUB_CMD_LINUX (GRUB_CMD_LINUX="nomodeset") in /etc/default/grub and run sudo update-grub. Reboot.

share|improve this answer
1  
When I add "nomodeset" to the GRUB options everything runs super slow. Solutions? –  xj9 Jul 26 '13 at 22:48
    
@xj9 They've finally released a fix. See answer below :) –  Jake Stoeffler Mar 6 at 20:58

I know this question is over two years old, but using nomodeset was not a viable option for me as it made my machine extremely sluggish, not to mention the lower screen resolution. Fortunately, a fix has finally been released in version 3.13-rc5 of the Ubuntu Kernel. Here's what I did to upgrade my 12.04 LTS install (which was running 3.11):

mkdir kernel-v3.13-rc8-trusty && cd kernel-v3.13-rc8-trusty/
wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.13-rc8-trusty/linux-headers-3.13.0-031300rc8-generic_3.13.0-031300rc8.201401120535_amd64.deb
wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.13-rc8-trusty/linux-headers-3.13.0-031300rc8_3.13.0-031300rc8.201401120535_all.deb
wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.13-rc8-trusty/linux-image-3.13.0-031300rc8-generic_3.13.0-031300rc8.201401120535_amd64.deb
sudo dpkg -i *.deb
sudo reboot now

(You can substitute "v3.13-rc8-trusty" with another version (all of which you can see here) if you wish, so long as it's post-3.13-rc5).

I suspect that the same garbled-screen issue occurs on other netbooks with similar ATI graphics cards (rs690/x1200/x1250), and this approach should work for those cases as well.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.