Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Strange, I have change folder users/groups to www-data (sudo chown -R www-data:www-data /datos/www) and also have changed permission to 755 (sudo chmod -R 755 /datos/www), but still getting 403 Forbidden problem with Apache. Tried to find out apache user in the process list and here is the result:

bakhtiyor@sony-vaio:/var/www$ ps aux | grep apache2
root      6627  0.1  0.2 158128  9244 ?        Ss   23:23   0:00 /usr/sbin/apache2 -k start
www-data  6632  0.0  0.1 158152  5348 ?        S    23:23   0:00 /usr/sbin/apache2 -k start
www-data  6633  0.0  0.1 158152  5348 ?        S    23:23   0:00 /usr/sbin/apache2 -k start
www-data  6634  0.0  0.1 158152  5348 ?        S    23:23   0:00 /usr/sbin/apache2 -k start
www-data  6635  0.0  0.1 158152  5348 ?        S    23:23   0:00 /usr/sbin/apache2 -k start
www-data  6636  0.0  0.1 158152  5348 ?        S    23:23   0:00 /usr/sbin/apache2 -k start
1000      6681  0.0  0.0  13468   896 pts/0    S+   23:23   0:00 grep --color=auto apache2

Apache configuration file for my virtual host is here:

<VirtualHost indextj:80>
    ServerAdmin webmaster@indextj

    DocumentRoot /datos/www
    <Directory />
            Options FollowSymLinks
            AllowOverride None
    </Directory>
    <Directory /datos/www/>
            Options Indexes FollowSymLinks MultiViews
            AllowOverride None
            Order allow,deny
            allow from all
    </Directory>
    ...
    ...
</VirtualHost>

Is it something related to the first process of apache that has been run under root? Even though I don't know why apache is running under root user.

Need some ideas about solving this strange issue.

Thank you

share|improve this question

2 Answers 2

up vote 3 down vote accepted

Theres something weird in this conf. Don't quite understaind it...

<VirtualHost indextj:80>
    ServerAdmin webmaster@indextj

    DocumentRoot /datos/www
    <Directory />
            Options FollowSymLinks
            AllowOverride None
    </Directory>
    <Directory /datos/www/>
            Options Indexes FollowSymLinks MultiViews
            AllowOverride None
            Order allow,deny
            allow from all
    </Directory>
    ...
    ...
</VirtualHost>

but at first sight I can tell you to chanche AllowOverride to All. this is the conf of my wiki for example.

<Directory /var/lib/mediawiki/>
        Options +FollowSymLinks
        AllowOverride All
        order allow,deny
        allow from all
</Directory>
share|improve this answer
    
hmm...worked, I don't know what is going on... –  Bakhtiyor Nov 2 '11 at 23:23

Try adding Allow from All inside

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.