Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed gdm for a while as my display manager, and after removing it, lightdm does not start by itself. I instead have to login to a tty, and run sudo start lightdm.

Running dpkg-reconfigure lightdm does not work either:

dpkg-maintscript-helper: warning: environment variable DPKG_MAINTSCRIPT_NAME missing
dpkg-maintscript-helper: warning: environment variable DPKG_MAINTSCRIPT_PACKAGE missing

I've also tried reinstalling lightdm completely, but it does not work as well

My /var/log/boot.log has the following lines:

* Starting LightDM Display Manager                                                                                                                  
* Starting ACPI daemon                                                                                                                              
* Starting anac(h)ronistic cron                                                                                                                     
* Starting save kernel messages                                                                                                                      
* Stopping LightDM Display Manager         
share|improve this question

3 Answers 3

up vote 22 down vote accepted

Run a terminal and enter cat /etc/X11/default-display-manager. Probably says lightdm if you recently uninstalled GDM. /etc/init/lightdm.conf doesn't accept lightdm as a setting - however, /usr/bin/lightdm or /usr/sbin/lightdm work. So open /etc/X11/default-display-manager in your favorite text editor and replace whatever is there with the following line:

/usr/bin/lightdm

or

/usr/sbin/lightdm

Reboot and lightdm should start and bring you to the logon screen as usual.

share|improve this answer

Alright, I think I finally figured it out! Everyone's suggestion in response to this problem is to get the right legacy nVidia card. Easier said than done. I had a really hard time tracking down the right driver, since it seemed to have disappeared from repositories (at least Ubuntu's). Here's what worked for me. Depending on your nVidia card, you might need to download a different file, but they're all listed at http://www.nvidia.com/object/unix.html. I needed the legacy 96xx driver for my GeForce 2 MX 400. So, after weeks of trying to fix this, I just ran these commands and it finally worked! The URL used in the wget command is just the URL of the file that the nVidia website wanted me to download.

wget http://us.download.nvidia.com/XFree86/Linux-x86/96.43.23/NVIDIA-Linux-x86-96.43.23-pkg1.run
sudo sh NVIDIA-Linux-x86-96.43.23-pkg1.run
sudo reboot
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.