Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

How do I set Nautilus to be the default file manager in Xubuntu?
Should I expect any trouble with this choice compared to normal gnome nautilus setup?

share|improve this question

4 Answers 4

up vote 10 down vote accepted

Install the package called exo-utils. Then press Alt+F2 and run the command exo-preferred-applications. In Preferred Applications, click on the Utilities tab, and under File Manager, select Nautilus. (You must install Nautilus first, if you haven't already.)

share|improve this answer
    
The only problem with this is that thunar still loads at startup, I'll make a startup script to correct for that, since thunar shuts down when nautilus starts. –  enedene Nov 2 '11 at 21:52
    
This way Thunar is also the browser that's opened when a new external drive/memory card is inserted -- I don't know how to stop that happening, but actually removing the thunar package doesn't seem to be an (easy) option as that results in removing the whole xbuntu-desktop package... –  andybuckley Feb 23 '13 at 14:16
    
@andybuckley Sorry I didn't reply before. I'm not sure why Xubuntu still opens when new media are mounted; you might want to ask a separate question about that. Regarding removing Thunar: if you're not going to use it, and removing it wouldn't cause any other packages (besides xubuntu-desktop) to be removed, then you can probably go ahead and remove it without problems. xubuntu-desktop is a metapackage that doesn't provide any software directly. Just reinstall xubuntu-desktop before upgrading to the next [X]Ubuntu release. –  Eliah Kagan Jul 28 '13 at 8:48

You can also find a good how-to on the wiki page (changing to thunar for example): https://help.ubuntu.com/community/DefaultFileManager

Where you can change the /usr/share/applications/defaults.list or better ~/.local/share/applications/defaults.list. You can even modify your .desktop files if you want.

share|improve this answer

I see these are all for older versions, but here is the answer for 12.04+

In menu/settings/preferred applictions (In 12.04) or, I think, in menu/system settings, preferred applications in 12.10+ there is a tab "utilities." Change the preferred file manager to any in the list you have installed, or type one in (this works for say, Marlin.) If you get an error and are using a non-native file manager such as Dolphin (KDE) or Nautilus (Gnome) make sure you have "start gnome services" and/or "start KDE services" in the session and startup part of system settings manager, it's in the advanced tab on the far right. Be aware this will start ALL Gnome and/or KDE services so marked for startup.

share|improve this answer

I've used Nautilus safely in Xubuntu under the 11.04 release. Bare in mind however that by default, launching Nautilus may also load several Gnome desktop features.

At the time I used gconf-editor to modify the variable /apps/nautilus/preferences/show_desktop to "false" and /desktop/gnome/background/draw_background to "false". This stopped the desktop showing.

I haven't played with Xubuntu 11.10 yet so I cannot confirm what the experience is like there. I imagine that given the Gnome stack has been bumped to 3.x there will be differences.

I hope this at least has given you an idea of what you might encounter and how to deal with it.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.