Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Could anyone please help me ?? when I try to connect my iphone 4s I get this message :unhandeled lockdown error(-15) . It worked just fine so far and I have no idea how to fix it .

share|improve this question

5 Answers 5

Lines in code need to be typed into terminal.

  1. sudo apt-get install ifuse libimobiledevice-utils
  2. Unlock iDevice from device's lock screen, plug it in
  3. idevicepair unpair && idevicepair pair
  4. Unplug the iDevice
  5. Make sure the lock screen is still unlocked
  6. Plug it back in
share|improve this answer
    
Thanks! That fixed it! –  jaorizabal Mar 5 '12 at 2:45

Ubuntu uses libimobiledevice, a software library which handles iPod, iPad and iPhone devices. iPhone 4S comes with iOS 5. The version of libimobiledevice that ships with Ubuntu id not support devices running iOS 5, however there have been an update released.

https://bugs.launchpad.net/ubuntu/+source/libimobiledevice/+bug/795475 https://bugs.launchpad.net/ubuntu/+source/libimobiledevice/+bug/882039

Run ideviceinfo -d to see if your phone shows up.

share|improve this answer

another right procedure to avoid the message error "Unable to mount IPhone"

press simultaneously [Ctrl]+[Alt]+[T] //open terminal

type ----> sudo apt-get install ifuse libimobiledevice-utils

insert your password , then Unlock iPhone from slide's lock , plug it in to usb port.

type now into terminal ---> idevicepair unpair && idevicepair pair

Unplug the iPhone

pain attention check if your Iphone have screen still unlocked

plug it in to usb port. and that's it!

share|improve this answer

Also, if it worked in the first place, but then you reset the iPhone (used Erase all Content and Settings option in the Reset menu in Settings) and it stopped mounting, then the solution is to remove the ~/.config/libimobiledevice/ directory and then replug your iPhone.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.