Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Using VMWare, I am running Kubuntu as a Guest OS on top of a Windows OS.

I have tried installing the VMWare tools but it fails to initialise the guest OS system daemon. It seems to be a fairly common problem, and can become quite a headache to solve.

Someone recommended to install open-vm-tools but there is not much information about and I do not know where to start.

Any one has done this before. Any help on how to share my files between my windows host OS and Linux guest OS will be greatly appreciated.

share|improve this question

1 Answer 1

up vote 2 down vote accepted

Use samba in your guest OS and share them in your network, follow guides online to make it secure and if you just want to copy files from guest to host then make them read only. That way it's only available when your guest vm is on and even then it's read-only.

I have had no problems drag and dropping files between guest and host OS with Linux as a guest and Windows as host. The only issue I have had is using a KDE linux distro as a host since they dont account for plasma and as such it never puts the file where I want it, but I figured out that the file gets transfered to a tmp folder and now I just have a link to that folder in my desktop widget. I don't remember having that same issue with it as a guest on a windows host though.

When files are dragged and dropped with a Kubuntu host/guest they go into a temp folder: /tmp/VMwareDnD/ so you could search there if they don't show up where you dragged them to.

share|improve this answer
    
For some reason when I install the VMware tools it says that the guest operating system daemon failed, and aborts the execution. Any ideas? –  Peretz Nov 1 '11 at 18:27
    
Hey Marlon, I have added the output to pastebin (quite cool website, I did not know about it). pastebin.com/xHrkDKdE –  Peretz Nov 1 '11 at 20:18
    
how do you mount the sharing folder? shouldn't mount automatically? –  Peretz Nov 1 '11 at 21:04
    
vmware.com/support/ws4/doc/running_sharefold_ws.html for instructions –  Marlon Nov 1 '11 at 21:07
    
fix for the main issue that prompted this question is here: askubuntu.com/questions/74484/… I deleted all other comments for clarity and brevity –  Marlon Nov 2 '11 at 7:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.