Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed Ubuntu 11.10 after booting it from a USB drive. Everything worked fine there, after booting the keyboard worked in grub but not after Ubuntu was booted. I can unplug either of them and plug them in via a PS2/USB adapter and the device will work. After switching a couple of times, I got the keyboard and mouse both working via usb but after I rebooted either stopped working. How can I fix this?

The mouse is a Razer Krait and the keyboard is a Logitech ClassicKeyboard 200.

share|improve this question

closed as off topic by jrg May 21 '12 at 20:34

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Check if the devices show up in lsusb. –  Anonymous Nov 1 '11 at 19:55
    
I find that some times if you just let the computer sit for about ten minutes the mouse and keyboard come back up. –  user32562 Nov 6 '11 at 14:00
    
that may be the case, yes. but thats not a solution to the problem. –  crstn Nov 6 '11 at 17:29
    
Try the workaround mentioned in this bug report - the bug is known to cause delays with some input devices. –  htorque Jan 2 '12 at 21:56

protected by Community Apr 19 '12 at 8:23

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Browse other questions tagged or ask your own question.