Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Ubuntu's new policy dictates that updates to already installed applications don't require password when doing it from Update Manager (Synaptic and apt-get still require password). Also, I would like to prevent the Update Manager to pop-up, it should only run when I invoke it. Thanks.

share|improve this question
1  
You can get the update manager to ask you for updates by going to Software Sources. Under the Updates tab, change the Automatically Check for Updates value to "Never". –  Kris Harper Nov 1 '11 at 16:05
    
@KrisHarper I am running 12.04. Where do I have to make change? "Software Sources", where are they? –  kamyogi Dec 13 '13 at 11:36
    
@kamyogi I can't check right now, but Software Sources should either be available in the Dash, or in one of the menus in the Software Center. –  Kris Harper Dec 13 '13 at 13:53

1 Answer 1

up vote 3 down vote accepted

To remove the 'update packages without admin auth'

gksudo gedit /var/lib/polkit-1/localauthority/10-vendor.d/com.ubuntu.desktop.pkla

The section in question is this

[Update already installed software]
Identity=unix-group:admin
Action=org.debian.apt.upgrade-packages
ResultActive=yes

Probably the easiest & maybe best solution is to just remove the whole section.

If desired you could leave & try setting the ResultActive=yes to this

ResultActive=auth_admin_keep

If I wanted this I'd just remove the section, then the action should fallback to the default in /usr/share/polkit-1/actions/org.debian.apt.policy which is to require auth per use.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.