Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have an exclamation point saying "The update information is outdated" which has appeared today (2016-10-03), and when I ran the update manager I got an error message that it failed to download information. (By the way, there is nothing wrong with my internet connection.)

enter image description here


The command: sudo apt-get update gives me this error message after an attempt to update:

W: Failed to fetch http://dl.google.com/linux/chrome/deb/dists/stable/Release  Unable to find expected entry 'main/binary-i386/Packages' in Release file (Wrong sources.list entry or malformed file)

E: Some index files failed to download. They have been ignored, or old ones used instead.

Google Chrome seems to be giving me a hard time?

share|improve this question
    
Run sudo apt get update and add the output to your question. – Pilot6 Mar 10 at 10:35
up vote 13 down vote accepted

Source of this solution:

sudo sed -i -e 's/deb http/deb [arch=amd64] http/' "/etc/apt/sources.list.d/google-chrome.list"

then update with

sudo apt-get update

and everything will be fine.


Long explanation: Google Chrome packages put automatically their repository file in /etc/apt/sources.list.d/.
Since the beginning of March the 32 bit (i386) repository has been disabled - see this question for more details.
Unfortunately they forgot to update the information on their source file!
The problem was then solved since version 49.0.2623.87 of Google Chrome, but for previous versions the above procedure is a workaround to this problem.

share|improve this answer
    
Yes good call, fixed my crome - that dumped the error yesterday, but I didn't manage to report this error before this post – Ken Mollerup Mar 10 at 10:55
    
yep. Works like a charm. Cheers. – Elysium Mar 10 at 13:46
    
Great to hear! :) – dadexix86 Mar 10 at 15:23
    
is this related to this askubuntu.com/questions/743912/… ? – lapisdecor Mar 10 at 21:35
1  
@lapsidecor no, this is a different problem. – dadexix86 Mar 10 at 21:38

For me on Ubuntu 14.04.3 I also had to update:

sudo nano /etc/apt/sources.list.d/google.list

Which had:

deb http://dl.google.com/linux/chrome/deb/ stable main

with:

deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main

OR just terminal:

sudo sed -i -e 's/deb http/deb [arch=amd64] http/' "/etc/apt/sources.list.d/google.list"

Same issue with google-webdesigner

sudo sed -i -e 's/deb http/deb [arch=amd64] http/' "/etc/apt/sources.list.d/google-webdesigner.list"

NEW FILE:
$ cat /etc/apt/sources.list.d/google-webdesigner.list deb [arch=amd64] http://dl.google.com/linux/webdesigner/deb/ stable main


PREVIOUS VERSION:
$ cat /etc/apt/sources.list.d/google-webdesigner.list.save deb http://dl.google.com/linux/webdesigner/deb/ stable main

& now an new error:
W: Duplicate sources.list entry http://dl.google.com/linux/chrome/deb/ stable/main amd64 Packages (/var/lib/apt/lists/dl.google.com_linux_chrome_deb_dists_stable_main_binary-amd64_Packages) W: You may want to run apt-get update to correct these problems

Just remove:
sudo rm /etc/apt/sources.list.d/google.list

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.