Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When searching for solutions to cursor jumping around, I found a lot of references to touchfreeze - a package that disables touchpad while typing. Only it is no longer part of any repository that I can find. All links to it are invalid.

share|improve this question
up vote 8 down vote accepted

You do not need a separate application to achieve that.

On 14.04

Simply run:

gsettings set org.gnome.settings-daemon.peripherals.touchpad disable-while-typing true

or

gsettings set org.gnome.settings-daemon.peripherals.touchpad disable-while-typing false

to either disable or enable touchpad while typing.

On 15.04+

You can use syndaemon in the background

To add syndaemon to startup applications:

Dash > Startup Applications > Add. Add the command:

/bin/bash -c "sleep 15 && syndaemon"

Explanation

The cleanest solution is to use:

gsettings set org.gnome.settings-daemon.peripherals.touchpad disable-while-typing true

However, the key does not exist in versions, later than 14.04. I tested syndaemon on my 15.10 laptop, and it did the job perfectly.

Syndaemon has a number op options, of which the following seem the most important to me in your situation:

-i <idle-time>
    How many seconds to wait after the last key press before enabling the touchpad. (default is 2.0s). 
-m <poll-interval>
    How many milliseconds to wait between two polling intervals. If this value is too low, it will cause unnecessary wake-ups. If this value is too high, some key presses (press and release happen between two intervals) may not be noticed. This switch has no effect when running with -R. Default is 200ms. 

See also man syndaemon

share|improve this answer
1  
Interesting. I do not have that gsettings schema. I do have org.gnome.desktop.peripherals.touchpad, but only basic settings there. disable-while-typing not part of it. I also have several or.gnome.settings-daemon-peripherals, such as mouse, touchscreen, etc - but touchpad is not one of them. Must be missing more advanced drivers... Ideas? – KateYoak Mar 7 at 23:59
    
@KateYoak it turns out the key does not exist any more in versions, later than 14.04. See my updated answer. – Jacob Vlijm Mar 8 at 9:01

The package was removed after 10.04 (and 10.04 is no longer supported, which is why you can't find it in the repositories). From the publishing history on Launchpad:

Removal requested on 2010-07-28.
Deleted on 2010-07-28 by Jonathan Riddell
(From Debian) ROM; superior alternative exists, never in stable; Debian bug #587415

The Debian bug report mentioned says:

Please consider removing touchfreeze from Debian:

  • kde-config-touchpad is far superior software with many improvements over touchfreeze

    • excellent KDE integration
    • far more feature-full
    • actively developed
  • touchfreeze was never in a Debian release so far

Sp, perhaps you should look into this kde-config-touchpad, whatever that is, if it still exists.

share|improve this answer

The other answers are excellent, but I'd just like to note that in the "Touchpad" pane of the settings screen for "Mouse and Touchpad" in 15.10, there's a tickbox that says "disable touchpad while typing" and which does what it says on the tin.

This is Cinnamon with a theme so Unity or other desktops will look different but I promise the button is in the same spot :) enter image description here

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.