Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

In 11.10 the ability to write to NTFS drives was removed. There are ways around this, like ntfs-config, which mounts the selected drives as r/w, but I'm looking for a more permanent solution. I have also tried enabling it in the kernel (when compiling) but that doesn't seem to do anything.

tl:dr I want for NTFS drives (including removable ones) to be mounted r/w instead of r/o (from gnome-shell and nautilus), like in 10.10 and 11.04

share|improve this question
add comment

3 Answers 3

up vote 3 down vote accepted

I use NTFS-config and it mounts all me external and internal drives with write capabilities

just run this in commandline after installing ntfs-config

sudo mkdir -p /etc/hal/fdi/policy

this will make ntfs config run and u can enable read write

share|improve this answer
    
But I would like them to be seamlessly mounted through the filemanager as r/w, as I consider ntfs-config (on my computer at least) to be clunky. EDIT: Does the two check boxes effect other mounting, or just drives mounted through NTFS-Config? –  NRoach44 Nov 1 '11 at 8:20
    
OK, thanks, I retried using NTFS-Config and it does seem to modify the system settings. Thank you! –  NRoach44 Nov 1 '11 at 9:15
add comment

am posting the fstab entry for ntfs on my system ...

am able to write Ubuntu 11.10 i386 ...

# /media/NTFS was on /dev/sda3 during installation
UUID=4E842157842142B7 /media/NTFS     ntfs    defaults,umask=007,gid=46                0       0
share|improve this answer
    
Thanks, but fstab only effects drives plugged in at boot, and my machines often stay on long. This is not a good solution for removable drives. –  NRoach44 Nov 1 '11 at 8:53
    
I use 1TB iOMEGA USB 2.0 Powered Ext HDD having (Samsung disk ) which mounts automatically in Ubuntu 11.10 with read write capability ..has two partition each formatted with NTFS –  joe1983 Nov 1 '11 at 14:56
    
I have a 1TB Seagate Freeagent USB 2 powered external drive which also automounted with write capability but from yesterday I cant write to it for some weird reason. Wonder if there is a setting which disables it. –  Hannes Nov 8 '11 at 7:59
add comment

I had the same issue. resolved by installing ntfs-config using :

sudo apt-get install ntfs-config

then

sudo mkdir -p /etc/hal/fdi/policy

I had a problem of dependencies when I used :

sudo aptitude install ntfs-config Don't use aptitude but apt-get

  • Writing in NTFS partition is not possible unless the package ntfs-3g is installed (this latter was removed in ubuntu 11.10 while keeping ntfsprogs instead)
share|improve this answer
1  
THANK YOU!! It worked perfectly! –  Hannes Nov 10 '11 at 21:23
    
You're welcome :) –  Hanynowsky Nov 11 '11 at 3:28
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.