Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a very weird problem.

I am running 11.10 on one of my computers which has the primary purpose of running XBMC. This computer cannot connect to mirrors.xbmc.org, which has addons, updates, etc.

baker:~$ ping mirrors.xbmc.org
PING mirrors.xbmc.org (212.110.166.220) 56(84) bytes of data.
From baker.local (192.168.1.100) icmp_seq=1 Destination Host Unreachable
From baker.local (192.168.1.100) icmp_seq=2 Destination Host Unreachable
From baker.local (192.168.1.100) icmp_seq=3 Destination Host Unreachable

But!

baker:~$ ping canonical.com
PING canonical.com (91.189.94.253) 56(84) bytes of data.
64 bytes from vostok.canonical.com (91.189.94.253): icmp_req=1 ttl=47 time=184 ms
64 bytes from vostok.canonical.com (91.189.94.253): icmp_req=2 ttl=47 time=184 ms
64 bytes from vostok.canonical.com (91.189.94.253): icmp_req=3 ttl=47 time=184 ms

Pretty much any other site on the internet that I've randomly tries also works.

From another computer on the network:

Cypress:~$ ping mirrors.xbmc.org
PING mirrors.xbmc.org (212.110.166.220) 56(84) bytes of data.
64 bytes from atlantis.xbmc.org (212.110.166.220): icmp_req=1 ttl=48 time=186 ms
64 bytes from atlantis.xbmc.org (212.110.166.220): icmp_req=2 ttl=48 time=186 ms
64 bytes from atlantis.xbmc.org (212.110.166.220): icmp_req=3 ttl=48 time=194 ms

If I try pinging the IP directly, the same thing results. It does not look like a DNS problem, something else. I've grepped my entire /etc folder for either that URL or that IP address to see if I had accidentally set something to 'please fail on this IP'. Nothing.

Also, a tracepath from baker, the bad machine:

baker:~$ tracepath 212.110.166.220
1:  baker.local                                           0.081ms pmtu 1500
1:  baker.local                                         3001.459ms !H
 Resume: pmtu 1500 

It almost seems like that machine has decided that it just can't route to it. From what I gather !H means the host is unavailable. Which it isn't.

I lack the networking terminology to search further and could use some help in identifying what's going on here.

share|improve this question
1  
Could you add the output of ip route show ? –  Jeremy Kerr Nov 1 '11 at 6:51
    
I ended up spending a couple more hours after this and ultimately solved it. I'm going to write up my troubleshooting steps when I get home in case this happens again. Long story short, that is exactly the correct question to ask and learning 'route -n' put me down the path of the actual solution. –  bikesandcode Nov 1 '11 at 15:58
    
Glad you got it sorted. Make sure you add your troubleshooting notes here too! :) –  Jeremy Kerr Nov 1 '11 at 18:28
add comment

1 Answer

The short answer was I had chosen the wrong gateway on that machine. Near as I can tell, this was the order of events:

  1. Computer was setup using DHCP, no problems.
  2. I edited /etc/network/interfaces to give that machine a static IP. No problems, right gateway.
  3. At some point after this, probably a few weeks, for some reason I used a GUI thing to mess around with networking settings. At this point, I mistakenly changed my gateway settings to the wrong router.

This is where it got weird. Either the computer or the wrong router had some sort of partial routing table or something, causing the initial problem.

The key command which ultimately sorted this for me:

route -n

When learning about ip tables and that sort of thing, I came across that command. I ran it and saw the gateway was the wrong router. I checked /etc/network/interfaces which no longer had my static block in it.

I put that back in there with the correct router's IP address and everything works.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.