Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I want to install LAMP in Ubuntu 14.04, but I have a problem with this command:

root@ubuntu:~# sudo nano/etc/apache2/mods-enabled/dir.conf

When run, the error "command not found" occurs.

What should I do to continue this installation?

share|improve this question
1  
You're missing a space between nano and /etc/apache2/mods-enabled/dir.conf, also sudo is not required if you're root: nano /etc/apache2/mods-enabled/dir.conf. – kos Mar 8 at 6:11

In the command you provided there is a space character missing between nano and the following path. Use:

sudo nano /etc/apache2/mods-enabled/dir.conf

sudo is a command that takes another command as an argument. In this case that other command should be nano however if there was no space after, shell would try to execute dir.conf from nano/etc/apache2/mods-enabled/ directory. As it does not exist, shell returns error about non-existing command.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.